Sync cannot add new device "deprecated version"


Description of the issue:
I currently have a sync chain consisting of (5) devices, which is a combination of Android and Windows machines. I am trying to add a new Windows laptop. When inputting the 25-word code, I get the error message, “The code was generated by a deprecated version of Brave, please upgrade your other device first.”

The code shows as 25-words on the PC I am using to “Add new device” and I have confirmed that the 25th word is the correct one for today.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Always happens on the new machine.

Brave Version(See the About Brave page in the main menu):
v1.52.130 (on both pc’s)

Type of devices currently running on the Sync chain in question:
Chain consists of (2) Android and (3) Windows devices. I am trying to add a 4th Windows device (eventually my old laptop will be removed from the sync chain).

Additional Information:
None that I can think of. I seem to be on the latest version of Brave on both machines.


The 25th word updates daily, so that’s why you get the message. You need to replace it with the one that website shows.

1 Like

I did use the 25th word from the link.

Are we permitted to disclose the word I got from the link on this forum? I’d like to check it as the code displayed on the pc which I used to “add device” also was 25 words and the last word was the same as the one I saw when I used the link.

If correct it would mean that Brave on my “source” was already pulling word 25 into the code meaning no need to check the link.

Derek Kozacko

The 25th word is a daily word, you can easily get it from a list of words, but using websites is the easiest way, you can right click and see it with Devtools in console by typing bip39Words in console, as you can see it is the BIP39 word list, which you can find many websites for it, but basically, it is this one list one word at a time per day.

The word for today is cushion and yesterday it was curve and tomorrow is custom but maybe timezone matters when doing the daily thing and for Brave to check the 25th word against their servers, yesterday it Brave is a USA company and from San Francisco, so you would have to think, maybe they will use that time zone, but you can see here what each error message means in Brave sync.

Also, if anything, deleting the sync chain and starting a new one could be the alternative, easier to do than troubleshoot why the code and if the daily is correct and if the 24 words are okay. Are you even sure you were using 25 words and not 24? well, then deleting the chain and making a new one would be easier and you will just keep synching the same thing you were synching already or planning to sync.

In other words, stop wasting time and since you can create many sync chains in Brave, and it is not tied to a phone number or email address and it is easy to create and delete, then, take advantage of it.

Thank you for the help.

I think this issue must have been time zone related. It worked the first time I tried it today. I was using “curve” yesterday and “cushion” today.

One thing I did want to make clear in case anyone else happens upon this. The 25th word populated automatically on the “source” browser that I was using to add the device. It wasn’t really clear to me if this code was supposed to only have 24 words (and I had to pull and add the 25th or daily word myself). This was not the case, it was automatic.

I am running into a similar issue. I have a 24 work sync code. Using only 24 words, I get the deprecated version error. When I add the 25th word from (

I receive the following error

Internal sync setup error

Please advise, thanks!

My issue was caused by invisible characters in the sync chain string.
For anyone else still struggling with this, please check if brave counts 25 words or copy the string into an advanced text or code editor like sublime, notepad++ or vscode.


In my case, the mobile version of Brave had replaced some spaces by a different character --as per the image-- and the same browser was NOT recognising all 25 words for that reason.

The solution is --obviously-- to type the words manually or clean them by replacing the spaces in between.

I hope this helps (or it gets fixed by the developers, at least).