Sync bookmarks not working across devices

Sync does not work across devices. I will be switching to another browser. I see no benifit to using brave now that youtube shows ads and my bookmarks won’t sync

It doesn’t show ads. If you’re having issues, it seems you’re not keeping things updated or you’re using extensions that cause issues.

Sure they will. Guessing you either don’t have things on same sync chain or you didn’t choose to sync bookmarks. If you don’t choose the option on both devices, then it won’t happen. Of course, you could have also asked for assistance in which case we could have seen if there’s any other issue, such as discussed at Sync stops working randomly and cannot be restarted without new sync chain. (Bookmarks no longer syncing, send to device no longer working reliably either.) - #58 by Alexey

Everything was updated and I had sync turned on. I even re sycned and made sure to have every option synced. I just turned off all the extensions and there were still youtube ads.

I’m sorry, I really did enjoy brave at first. It’s important that I have synced bookmarks at all times for my studies to keep in place and updated. I’m a amateur C and javascript programmer and I can assure you I exhausted all the options I could find in the settings. If I can remember correctly there are others having the same problem from the reddit search results I’ve looked at.

If there was a simple answer I couldnt find it. It shouldn’t be as difficult as it is to resync. I understand brave is in early development. Sorry for sound hostile mentioning I’m switching, but I might switch back. I enjoyed the no tracking features. I pay for youtube premium so the no ads isnt a problem, its the bookmark syncing that prohibited my effecient studying across devices

Just to be clear, I mean things like your components. Not sure if you haven’t noticed news over the past year or so, but all adblock have been going back and forth with YouTube, constantly having to update. We actually have tons of posts about it here, such as below:

I could do more, but just will leave it with those two. Like I said, if you go around Reddit and others you’ll find people on all browsers and all extensions have been having problems on occasion. YouTube changes things and then everyone updates filters. Brave works closely with uBlock and others.

Overall shouldn’t have problems. If ads do show, typically updating components and/or clearing cookies will resolve it. Tends to get fixed within couple hours of any changes made by Google. And if encounter on any other sites, just report and it gets resolved quickly.

Yeah, and like said, just comes down to troubleshooting. I mean, are you having the same issue as I and others did where it hit the limit? If so, going to brave://sync-internals and see if it shows any errors.

Actually, I went to screenshot it but it seems in the more recent updates, it ended up getting resolved. So might be good to know if you have any errors there and if showing synced.

Understood. Guess just wanting to figure out the “why.” Annoyingly enough, in the past it’s because people did not check off Bookmarks on one device but they did on another. When asking for screenshots, would see something like below:

It would be like, “umm, you need to turn on the toggle for bookmarks.”

Or we’d find that they would show screenshots like below, where they only have one device on the sync chain.

So I guess I’ve just learned to ask and never assume. No matter how smart someone is, mistakes get made.

All good. Guess I just wanted to jump on the idea of saying people can help look into issues and try to resolve. I know it showed you as a new account and the first post just was saying things don’t work and you’re leaving. It’s like, ffs…don’t want to give a chance to fix it first? lol

Anyway, sorry for the rambling. If you do want to try to work together to figure out the issue and get it resolved, do let me know. I’ll do what I can or will get people from Brave to directly assist.