Specific Website Cannot Be Reached On Brave

I can access the following urls on brave, but if i have a link to a file, when i hit download, it says "This site can’t be reached
www1.dropbay.net took too long to respond.

urls: [https://dropbay.net/] and (https://www1.dropbay.net/)

Did the issue present with [default Shields settings]
Yes, I tried with default shields and then disabled entirely, still does not work.

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
Does not appear to be.

Does the site work as expected when using Chrome?
Normal chrome, works flawlessly. And up until recently, Dropbay worked flawlessly on brave. However it just… Stopped working.

Brave version (check About Brave): [
Version 1.30.87 Chromium: 94.0.4606.71 (Official Build) (64-bit)

After posting this, chrome has seemed to stop working, and i’ve been told it’s a site issue by other users of the site. So i’m going to see if either brave or chrome starts working again eventually. Any suggestions appreciated but for now I will assume it’s a site issue

Just checked. Seems to be up and running.

Not the quickest site, but it loaded fine here. Are you using a vpn, or try using a vpn from a different location

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.