Some sites faulty show as unsafe on my old Mac, when it's fine in Brave on other device

Hi there,

I don’t know if it’s just me or anyone who has also noticed that too. I am using Brave on a iMac (2011), the latest macOS version which can update to is OS X EI Capitan 10.11.6(and it is updated to the latestversion). I had been using Brave for months, and loving it. But from a few hours ago, I noticed some sites I always visited started to shows as unsafe sites, when I didn’t change any setting at all. It’s quite irritating. I had checked from my phone and my air book, those sites work perfectly fine on Brave.
I had tried updating and redownloading Brave, but nothing seems to works. I even tried to sync my air book Brave setting with my old Mac’s one, but it still failed to work.
So my question is, is my mac too out of date for Brave all of a sudden? or is it any other reason? And how can I fix it?

Thanks in advance.



Thanks for reaching out.
Unless something changed that I don’t know about, macOS 10.11.0+ should still be supported. Can you share some example website that appear this way for you? Additionally, have you tried clearing your cache/browsing data to see if sites still appear this way? Alternatively/in addition, you can try creating a new temporary profile and see if you get the same results there.

Hello Mattches,

Thank you so much to get back in such a short amount of time. I had tried all three ways you provide, but none of them work sadly.
And sure, the sites I visited like,, etc. I didn’t always go on Brave, but Brave main site, and all related pages also show as unsafe. Wait!! Or am I be hacked :sob::sob::sob:?

Thank you for checking.
Would you be willing to download and install the beta build of the browser to test and see if the issue persists in the Beta? Note that installing/running the beta will not have any effect on your current Brave installation.

@Mattches ,

Can’t open any Brave page, so have to sent the package to the Mac. In short, I successfully downloaded it, but those sites(include Brave pages) still failed to work🥲

Check the date/time on the computer, which will cause invalid SSL requests. Checked both sites; (note the valid to-from dates). I would also update the OS, if any updates are available.


Hey @fanboynz ,

Thank you for your respond. I found out there is still one more version which my old Mac can be updated to, and I did. Now it works!! Thank you so much!!
Btw, I learnt from Apple support that some of the websites’ CSR or SSL might not support some old macOS system anymore. I think would be good if Brave can include support system on the website as a reference.
Thank you again fro your support!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.