Some site show mobile version on desktop

Hi

There are a few sites that will only show up as mobile versions on my Brave desktop browser. There seems to be no setting to force the desktop version of the webpage to load. I am using Brave on OSX and one of the sites is this one:

I tested that site in two other browsers and it loads the desktop version.

Is there a way to force Brave to load the desktop version of a website?

Thanks

@deadface,
Thanks for reaching out to us.
So I see the Desktop version loading for me on my end when I visit that same site (using macOS 10.15.4) in Brave stable.

A couple things come to mind:

  1. Do you have any extensions installed in the browser at this time? I know it seems weird but some extensions can cause weird conflicts like this – you might try disabling them (temporarily) to see if the behavior changes.
  2. Can you try right-clicking anywhere on the site and selecting Brave --> Clear CSS rules for this site and refresh the page to see if this changes the display?

Hi
Thanks for the reply. I do have some extensions. I have the google docs extension as well as zotero, both of which I need. I am not sure if this is a good test but I disabled both, right clicked and cleared the CSS rules as you stated, cleared the cache, and restarted the browser. I still get the mobile version of that site.

Is there anything else to try?

I did one more test. I logged into another account and had no issues with that site. So, I think I need to manually delete everything related to Brave and start over again since clearing the cache didn’t work. On OSX, where is the brave data stored?

OK. Just to wrap this up, I found the Brave file area and deleted everything. And I am all set on the sites that were giving me issues. Not sure what it was in the first place but I must have messed something up over time.

1 Like

If you encounter this issue again, you may want to check your zoom level for that site @deadface too.