Site permissions via desktop icon left of URL confusing & not helpful

So once upon a time Brave provided a method of adding any URL to a “whitelist”.
From what I can see, spending hours now, trying to find where this option is, or Was.
I cant find it. Searching google for an answer, I find that I should be able to see a “site permissions” selection in the Icon (Not Secure) to the left of the URL. OK, I tried that, and there is no quick way to select “allowed” or “whitelist” for this URL on the fly. Instead, you feel we have hours of time available to select the hundreds of site permissions selections (all-be-that-this-is-really cool), in the hope that we can then close and reopen the desktop browser repeatedly, and try the same secure URL - hoping to be able to open it.
Well - I must say, I have not been successful and I’m being forced to use a Firefox browser instead.
Not a happy day!!
FYI - the URL is a banking site “https://secure03b.chase.com/web/auth/dashboard

thanks for your many efforts

@labear,
Thank you for reaching out to us.
I do apologize but I’m not entirely sure what you’re describing here. The “lock” icon to the left of any URL allows you to view site information, such as the sites connection status and permissions granted (or blocked). You also have the option to jump directly to Site settings and Cookie settings for the site.

What exactly is it that you’re trying to whitelist? Are you trying to whitelist all cookies for this site or some other permission?

I’m purely trying to whitelist this URL (having allowed all cookies, etc) since it’s a bank I often access online.
I tried 10 separate attempts of modifying site permissions and I still cannot load the site page (provided above) using Brave.
Though no problem accessing page with Firefox desktop.

What happened to the selection where we could add a complete URL to a white list “allowed” site settings?

@labear,
On my end, I have no problem landing on the site and logging in under default settings. If you want to allow all cookies on this (or any) site, the easiest way to do this would be to do so via the Shields panel in the address bar:

Can you also tell me what happens when you do land on the page?

Hello again,
I’m sorry for the delay in responding. Your reply got caught in my spam folder.
Anyhow - I confirmed that my Shields are defaulted and that I still cannot reach this banking site.
I’m also not able to reach 20+ other sites, some of which are banking sites I need daily.
Anyhow, plz see the attached screenshot of my Shields Details page for this URL. It was shot overlying the Chase bank login page which I’m not able to open.

thank you, I hope you can figure what is causing this on my end.

labear