Shields aren't preventing auto-play video on some sites

Pages like this…

…and most other articles on SFGate include auto-playing video that floats in the lower-left corner.

Brave Shields should stop any video from loading, and auto-playing.

I can confirm the same problem with the Linux build of 1.8.95 on sites such as CNN and Sports Illustrated. It used to work flawlessly until 1.8.90 and the update to Chrome 81. I think this is an upstream problem created by Google and their never ending quest for more ad revenue. In the meantime I use an extension called AutoPlayStopper available in the Chrome web store and it works great. Give that a shot.

From what I can see by searching around this community, this has been a problem for over a year and Brave has done nothing to fix it, and as near as I can tell, has never once addressed the issue. Regardless of how you toggle the switch at brave://settings/content/autoplay, videos continue to auto-play unless you specifically block every site where you don’t want them. Why isn’t this being addressed?

Why is


That’s the same extension I wound up with. It does seem to do a good job. I’ve just gotten spoiled by the fact that I haven’t had to install any extensions on Brave before now, save for my password manager and Imagus.

I would understand if this were and upstream problem and the Brave team acknowledged it. I’m just disappointed that they’ve ignored these threads.

Agreed. I’m not fond of running any extensions at all but is all but unreadable without auto-play video blocking. GNOME Shell Integration (it’s a Linux extension) and AutoPlayStopper are the only extensions I currently run. Brave’s blocking of videos is what made me switch from Chrome in the first place. If this is indeed an upstream problem there may not be an easy fix, hence the delay.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.