Several Brave Components are not updating


Description of the issue:

After the latest update to Brave (v1.64.109 on March 20, 2024) The brave browser no longer bocks any ads, trackers etc. even with shields up. Looking at brave://components, several of them show “update error”.

How can this issue be reproduced?

Right away upon opening brave on desktop.

Expected result:

To be fixed

Brave Version( check About Brave):

v1.64.109

@jrp74 can you open Brave as administrator and see if it updates? I’m assuming it will as has been solution for others lately.

Opening as administrator does work, thank you. Unfortunately opening it regularly still does not. Is there a way to fix this?

Well, I’d say it’s some setting on a firewall, antivirus, or whatever on your computer that’s blocking it. I’d try to look into what you have that might be stopping things.

But otherwise, I guess can refer to someone else who shared the info linked/quoted below:

1 Like

This worked! Problem solved, thank you for help.

1 Like