Scroll Speed is too fast to be useful


Description of the issue:
The scroll speed is entirely too fast when I use my trackpad. I do not own a separate mouse as that would often be impractical for my use.

How can this issue be reproduced?

  1. Open a website with Brave.
  2. Try to scroll down just enough to see the next row of text with the trackpad
  3. Watch it scroll all the way to the bottom, and then back to the top when you try to scroll back to the middle of the page.

Expected result:
I should be able to scroll just enough to get to the next section of a site. In order to do that currently I have to move my mouse pointer to the scroll bar on the side of the page (Hello, 90’s).

Brave Version( check About Brave):
1.4.96

Additional Information:
I’m running Windows 10 on a Lenovo Ideapad 330. I only have this issue on Brave. I have changed my computer settings to slow the overall scroll speed, which has slowed it down to near ridiculous levels everywhere else, but still not within Brave. It is only giving me this issue with the Brave Browser. I’m a new user and so excited about the possibilities here, but I don’t know if it’s sustainable for me with this current issue.

3 Likes

I use a L330 and have to use two fingers to scroll via trackpad in Brave, Edge and Firefox. Mine is a lower end of the 330 line, the whole line being relatively low-end Lenovo.

Well, yes. The way the trackpad works you have to use two fingers to scroll. My problem is that when I barely move my fingers down to scroll it will scroll all the way to the bottom of the page. And when I barely move them up it will scroll all the way to the top again. Even with minute movements of my two fingers. THAT is the issue I’m having.

1 Like

@smithkjw,
Thanks for reaching out to us. That’s strange behavior indeed – I too have a Lenovo laptop and the trackpad seems to scroll fine in Brave. I’m wondering if it’s (for some weird reason) a Hardware Acceleration issue – can you try disabling and see if that helps the scrolling issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

1 Like

I tried that. No go. I’m really hoping someone can help me figure this out. Otherwise I love Brave!

1 Like

No issue here either. FYI, it’s the same with or without hardware acceleration enabled.

Is there any help for this issue? It is seriously slowing me down because I have to use the scroll bar on the side of the window. Am I just out of luck on this?

2 Likes

I’m hoping that someone has an idea to make this issue go away! I need a reasonable scroll speed within Brave!

@smithkjw,
Sorry for the late reply – and futher apologies for not knowing what to do about it. Generally, functions like this are controlled by the OS, other than certain flags/features of [any browser] that may alter scrolling behavior slightly (such as “smooth scrolling”).

Can you tell me if you have any extensions installed in the browser at this time?

Hi @smithkjw,
Could you try that, I saw some lenovo users who had the exact same problem on some applications.*

In the registry, under HKEY_CURRENT_USER\Software\Elantech\SmartPad,
set ScrollControl_Mode to 1 and reboot

I can help if you don’t know how to do it.

*https://www.reddit.com/r/techsupport/comments/3lhmhq/win10_elan_touchpad_scrolling_issues/
https://superuser.com/questions/1364774/elan-touchpad-sensitivity-per-application-in-windows-10-on-lenovo-flex-2-14

4 Likes

That seemed to do the trick! I had to dig around a little to find ScrollControl_Mode, because it obviously wasn’t in exactly the same place, but once I found it and changed 0 to 1 I can scroll smoothly from one page to the next in an ebook open in Brave! Before it would just jump from page 2 to 62 and then back up to one, etc.! Thank you! I’ve noticed several people have had this problem and brought it up without resolution on this forum. Hold on to this answer in case you run across it again! I will keep my eyes out for the need for it as well.

Thanks!

1 Like

Perfect,
Glad it’s solved :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.