Scaling issue Fedora 39 - Using ozone makes it too small

Hello, I have the same problem as this person:

My browser was blurry, so I set ozone to auto, which makes Brave sharp again. However, now the address bar and tabs are too small, it doesn’t seem that it respects the scaling i set (which is 150%). Any solution except disabling ozone again?

So this seems like a global Wayland issue with fractional scaling. I found a workaround to set the scaling to 200% and then reducing the gnome scaling to 0.8 (gsettings set org.gnome.desktop.interface text-scaling-factor 0.8) as well as adjusting icon sizes. It’s also possible to set it to 100% and then setting the scaling factor to 1.5, increasing icon sizes, mouse size etc. Play around and see what works best, but any increments in scaling don’t seem to work well and make the programs blurry. So it’s either 100%, 200%, 300% etc. instead of 150, 125%.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.