Brave 1.51.110 Scaling Bug LInux

Latest update has a bug for Wayland scaling in Linux. I run Fedora 38 with Wayland and my scaling is set to 125%. After update to latest version of Brave the browser will scale to 200%. This has been reported on the brave-browser reddit as well. This is not the first time this bug has happened according to web searches for this issue.

Same happens here. The only fix is to force to use X11 for now, but going back to X11 makes all the text and UI blurry.

Chrome has the same bug, BTW

Same here, I have to disable Ozone and work with a blurry mess.
Fractional scaling is so tiresome.

same here, rolled back to the previous Flatpak version:

sudo flatpak update --commit=2cbeea4c7ddb117f3680e6603bcf9cc799cf515f1e01ea7f1a3ff7e075115f94 com.brave.Browser
1 Like

I have this bug as well on Fedora KDE running Wayland. I ended up doing a dnf downgrade and dnf versionlock to go back to the previous version of Brave and prevent it from upgrading. I will try again when a new version makes it to the repo. It is unfortunate.

Just use dnf to downgrade to the previous version. That is what I did. You can also use versionlock to prevent it from upgrading again. I will try again on the next version release.

1 Like

downgraded it for the time being

1 Like

Update that came out today still does not fix this. Problem is not reproduce able in Chromium. It’s on Brave’s end. They haven’t even triaged the gitbhub bug report yet

Yes, it is NOT fixed in 1.51.114. :frowning:


Thanks for letting us know. At least I won’t need to try the update now.

1.51.118 finally fixes this problem


I am on Ubuntu 22.04 with Wayland HiDPI 200% scaling, and Brave with ozone enabled and 1.51.118 has not fixed the issue.

1 Like

Same here, running xwayland for now. Seems to be a problem for Chromium as well, so probably for all chrome-based browsers.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.