Safe Search won't keep "off" setting in a private window

Mac OS 11.6.7. When I open a private window and do a search, the safe search setting is “moderate”. I change it to “off” but the next time I open a private window it is back to “moderate”. Is there a way to keep it at “off”. This does not happen in a regular non private window. Is it because since it is a private window, no settings are saved and everything reverts back to default settings? This doesn’t make sense to me especially with a private window. I would think the default setting for safe search in a private window would be “off”. Thanks

@jmilt7 Hi and a belated welcome to the community. AFAIK this is working as intended. I find it a pain too. Besides setting safe search to strict, I always have to reset the “Anonymous local results” (disabled) and “Open links in new tab” (enabled) settings every time I use a new private window. If there is a way to set these permanently I haven’t figured it out!

If you want, you can edit your topic title (click pencil icon at end of title) and change the category to either Brave Search Feedback category or put it in the Brave Feature Requests category. Brave support and development staff do read these posts. :smiley:

Thanks for the response. I had a feeling that it is how you describe it. Which makes absolutely no sense to me. Why have safe search set to anything but “off” in a private window? Anyway, thanks again and I will try to follow up on your suggestion.