Brave does not retain position or size upon closing/opening ---It also shrinks! Video documentation included

1.After update, Brave no longer remembers position or size upon closing and reopening browser.

  1. Successive opening and closing creates a smaller and smaller Brave window until nothing is left but the title bar.

    (Video link included to illustrate bizarre behavior.)

Expected result:
The expected result is to have Brave not change its size or position and to not become the incredible shrinking browser.

Brave Version
Version 1.31.87 Chromium: 95.0.4638.54 (Official Build) (64-bit)

Additional Information:
Using Linux Mint 20.2 and have never had an issue with Brave over the last year, until now. Nothing was changed, altered, or modified in settings. The issue was seemingly created by the recent update.

Only actions taken to attempt to correct issue have been to clear history and disable speed dial plugin; each had no effect. Chromium browser which was updated at around the same time and has exactly the same plugins does not display this behavior.

Does anyone know of a Brave browser help board where I could receive some assistance with this issue? No offense, but this site doesn’t seem very helpful and it doesn’t seem anyone that develops or works on Brave is active here.

Maybe if someone has a link to an official Brave site they could direct me to that area. I’ve never been to a “help board” where you can’t even get the common courtesy of a reply like, “we are aware of the issue and will fix it with the next update” or “you have done something wrong and here is what you need to do” or even a “you are out of luck”, etc…

Stone silence doesn’t help too much.

I’ve noticed the same issue - latest stable version of Brave running on Linux Mint 20.0. Unfortunately this is the only place I’ve seen this problem mentioned. As a temporary fix I changed the shortcut on my launcher to use a fixed size on startup.

Edit the command to add “–window-size=xxx,yyy” where xxx and yyy are the size you want the window to be. Example: /usr/bin/brave-browser-stable --window-size=2300,1400 %U

Hope this helps for now and hope they fix this in a future update.


Thanks, WhyJustWhy. I’ll do that now and wait for the fix to roll out. I mean, I guess they will fix it. A person just has to guess because apparently no one that is associated with Brave visits this board or cares to respond to basic questions, which isn’t very encouraging.

I’ll upgrade my Mint VM to 20.2 and give it a whirl, see if I can reproduce the issue.

But I am not seeing your video demo, I don’t think. Is the link working and it’s just me?

I’m really not sure, Jim. It’s working for me, but that doesn’t mean anything. Here is a direct link that may work for you.

OK, saw your video. What a strange problem.

Sorry guys, couldn’t reproduce it in a VM. Maybe something video driver related? Curious if affected users might have something like that in common.

1 Like

Thanks for taking the time to investigate it, Jim. I can remedy the issue using WhyJustWhy’s workaround so, it’s not something that can’t be overcome.

Some Brave users may not visit this board though and will not know what to try.

Just in case anyone may need to do a comparison or something, here is my graphics information.

Graphics:  Device-1: NVIDIA GK208 [GeForce GT 720] driver: nvidia v: 470.74 bus ID: 01:00.0 
           chip ID: 10de:1286 
           Display: x11 server: X.Org 1.20.11 driver: nvidia 
           unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz 
           OpenGL: renderer: NVIDIA GeForce GT 720/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74 
           direct render: Yes  

I would like to add to the conversation that the Chromium browser I use is up to date also, was updated virtually at the same time as the Brave browser, has identical extensions, and is a exact clone of the Brave browser in how I have it customized.

It does not have this issue. This may lean towards it not being a graphical driver issue.

Also, in addition to WhyJustWhy and myself, here is another user of Brave having the same problem.

Shrinking Browser-Linux Mint Forum

One thing to ask, is it the same Chromium version as what’s underneath Brave? Brave periodically pulls up Chromium and then is subject to whatever bugs are present in that version – which may or may not be the same as whatever Chromium build the distro cuts a release at. Looks like the next Brave major release is due around Nov 19, although there could be another 1.31.x before them, and oftentimes those will pull Chromium up again.

One thing you could do is try a Nightly build and see if the issue is still present there, it will give you something of a glimpse into the future.

1 Like

Just a me too. I noticed a couple of nights ago that Brave restarted in smaller and smaller windows. I’m using LM Cinnamon 20.2 and Brave was recently updated.

I’ll try setting the window size in the launcher and wait for the next update.

[Update] Yep. Fixing the window size works ok. I’ll wait to see what happens after the next Brave update.


1 Like

I’m not really sure, Jim, if the versions match up or not. It seems like Brave is using a newer version of Chromium than the Chromium version I have installed.

Here is the Brave version:
Version 1.31.87 Chromium: 95.0.4638.54 (Official Build) (64-bit)

Here is the Chromium version:
Version 94.0.4606.81 (Official Build) for Linux Mint (64-bit)

Likely, as soon as Chromium updates again, both browsers will start shrinking. :frowning_face:


Bad news. Chromium was updated today, and as expected, it also shrinks and disappears upon successive openings and closings.

Version 95.0.4638.54 (Official Build) for Linux Mint (64-bit)

I’m afraid this issue will never be addressed and may just be a new feature that Google introduced and Brave is probably helpless to remedy it since they don’t really have control over all of Chromium’s code.

I guess I will try out Opera and maybe Vivaldi again, two other Google browsers, and see if they too have this new feature. I don’t really want to try Firefox again because they are political operatives now and may be working with the evil United States government to harm “certain types” of United States citizens even more earnestly than Google does.

Options are getting thin.

That’s unfortunate, but, have you tried a Nightly of Brave or a pre-release Chromium – whichever of the two gets you onto Chromium 96?

Seems like the Brave devs think they’ll be able to roll C96 into Brave Prod by end of Nov, and if you can get some confidence that the issue will be fixed then, it’s probably worth just letting it ride for a few weeks.

Or submit a bug report to the Chromium Bug Tracker if there’s not one already in there.

Actually, this is probably it right here:

Unfortunately it doesn’t seem to be getting a lot of attention at the moment. But if it were me I’d try the latest build I could get my hands on and see if the issue’s still there or not.

Thanks for that link, Jim, I really appreciate it. It seems like a few folks mentioned it, another guy came along and said it did not affect him and he would, graciously, leave it open for a little longer. Gee, that’s awful nice of him.

For the nightlies, I just don’t like going through the whole process on Linux if not absolutely necessary. Adding repo’s and all of that gets repetitive and leaves traces of stuff everywhere when you remove it.

And you know, it’s not really a huge deal with the provided fix but, it’s aggravating to know it isn’t right. I like for everything to be perfect. :grinning:

1 Like

Seems like it maybe something specific to your DE. I cannot reproduce it on Ubuntu and archlinux with unity and gnome-shell 40. Ubuntu of Xorg, Arch wayland.

Thanks for offering a suggestion, Kmod, but that isn’t it. Mint 20.2 has been installed for a couple of months and the Brave browser worked flawlessly with it until Brave and Chromium updated within the last week.

Nothing at all was changed with the Linux distro, the change was made with the browser.

As of the latest update [Version 1.32.106 Chromium: 96.0.4664.45 (Official Build) (64-bit)(Nov 16, 2021)], the problem seems to be fixed for me.

1 Like

Same here, WhyJustWhy, issue is now resolved after today’s update.

1 Like

Thanks to Jim and Kmod for offering suggestions and helping with this problem.

1 Like