Printing issues


Description of the issue:
How can this issue be reproduced?

  1. When I try to print from a webpage within Brave, Brave sees the AirPrint printer and connects to it. However, it won’t actually print. It just gets stuck saying it’s trying to Print. I don’t have this issue if I try to print from Safari.
  2. I’m running MacOS Big Sur ver. 11.2 on my MacBook Air.
  3. ShieldsUp is turned off for the site I’m trying to print from.

Expected result: I expect documents to print when I use the Print option in the browser.

Brave Version( check About Brave): Version 1.19.88 Chromium: 88.0.4324.96 (Official Build) (x86_64)

Additional Information: I’ve tried everything I can think of to resolve the issue and looked through the Community postings. Nothing helps.

1 Like

On Windows where my HP printer is connected via wifi, it can take up to 5 minutes to even begin printing. Did you wait a whole 5 minutes? If that doesn’t work try these steps:

  1. Reboot router.
  2. and reboot printer.
  3. Now try to print.

Me and several other people at work have had internet and wifi problems since December 2020 so I now have to reboot my router once a week. In the past I never rebooted it.

Thank you for your response. I’ve tried those things a bunch of times without luck. I’m wondering if my wifi printer is too old.

Yes that’s very possible. If your router doesn’t support older variants of 802.11 (there are several variants like “a”, and “b”, and some others) then that would be a problem. Or it could just be a cheap printer that cuts costs by only supporting newer variants.

Check your printer manual to see what wifi variants it supports, like 802.11a, 802.11b, etc.

Now check your router to see what variants it supports. I’m swinging wild so bear with me please. :slight_smile:

I’ll check. Thanks for the tip!