Brave not responding/crashes when printing

Every time I try to print, I have to wait 30 seconds where the browser becomes unresponsive before the printer highlights the “Save as PDF” option.

  1. Printing any pdf or image on any Wi-Fi hotspot still leads to an inevitable browser unresponsiveness
  2. Unable to select anything, cancel or interact with browser while unresponsive
  3. Once in a while a mini crash might occur
  4. It always seems to select “Save as PDF” as the 1st option, and this may be part of the problem.

I have tried restarts and updates to browser, nothing changes. I even have Microsoft Print to PDF disabled through Windows Features. I have not run into this problem on Firefox, but I’m not sure if it is a browser or system problem.

I’d appreciate any help please.

Brave Version:
Version 1.39.111
Chromium: 102.0.5005.61 (Official Build) (64-bit)

Running on Windows 11 Home, Build 22000.675

P.S. I have tried looking through the community and haven’t seen a solution, often times I see threads about this issue are opened and then closed without a solution being posted

@T_Ree

For testing . . .

Disable and then Remove any extensions that are PDF managers.

In a Brave Browser > New Window, go to: brave://settings/content/pdfDocuments

Select: Open PDFs in Brave

Visit: ‘http://www.pdf995.com/samples/

You can test both files:

  • widgets.pdf
  • widgets.txt

Open them, and then try to download or print.