Plex Server Issue

Brave Version: 1.34.80

If I login to my Plex Media Server (PMS) the checking for updates does not refresh and stays on checking for updates. See:

However, if I login with Chrome, FF or Edge to the same PMS it will refresh in the couple of secs. stating it’s either up to date or an update is available. I have cleared all data and cookies for this site and it does not help.

Any ideas appreciated.

TIA

1 Like

No one has any ideas?

Try disabling Brave Shields and refresh… Some things will break when scripts/etc. are blocked by the browser.

You could set custom exceptions to the script/cookie/fingerprinting/tracking if you identify what is blocked but should be allowed to run.

Or you could just use the Plex Web-GUI with Brave Shields disabled.

Should have mentioned Brave Shields already disabled for this site.

Or you could just use the Plex Web-GUI with Brave Shields disabled.

Get same results in Plex web-GUI

That is weird.

I disabled Brave Shields and unblocked 3rd party cookies for my server’s hostname, the plex.tv domain, and the app.plex.tv subdomain a LOOONG time ago, and I never had this problem.

Yes, very. Especially has it does not happen with the other browsers. I’ve also noticed other things not working in Plex when using Brave. eg: If a Movie or TV Show is watched on a device it’s not automatically updated in Brave until you refresh the page. Also if someone is watching something and your in the Dashboard page it will not show that someone is watching until you refresh the page.

It seems like all the things that should automatically change without a page refresh are not doing so. It does in other browsers though.

Probably because those other browsers you mentioned block NOTHING by default. Except maybe popups and some domains known to be notorious for malware.

Brave however has adjustable blocking of:

  • cookies
  • trackers
  • ads
  • fingerprinting

And can also:

  • Block ALL scripts
  • Force HTTPS instead of HTTP
  • Set/manage site/domain specific policies.

If you don’t know what you’re doing it is VERY easy to break web pages.

Especially those relying heavily on inline JavaScript or asynchronous calls/updates to/from backend server technologies.

So there’s no way to make Brave behave like the other Browsers for this one site? It is just that Brave is now the only Browser I use and I don’t what to use another just so one site works as it supposed to.

Like I said

1.Lower (disable) “Brave Shields”

Which means you should click the Brave Icon and you’ll see the Current state of Brave Shields and a single toggle switch to toggle all shields On or Off.

2.Refresh browser.

Which means: Hit F5 on your keyboard. Try Ctrl+R or click the "Refresh button if F5 did nothing.

Refreshing is done to make sure that the page reloads along with all external scripts/assets/etc.
like last time

But when, unlike last time, the shields are down, anything that got blocked earlier will now be loaded like in other browsers.

Brave will usually auto-refresh the page when shields are toggled, but better safe than sorry.

3.What if that didn’t work?

Permissons or restrictions specific to your Plex server may have been created if you toggled a bunch stuff on/off in an attemp to fix the page functionality.

Go into the setting and look for access permissions.

Either:

Remove all that contain your Plex server’s URL IP or Hostname to reset them to defaults and then toggle shields off and refresh the page.

Or:

Change them directly to remove/relax all restrictions.

  • Allow all cookies
  • Allow all fingerprinting
  • Allow all trackers & ads
  • Allow scripts (or do not block scripts)
  • Do not force HTTPS

Then you should only have to make sure the page gets refreshed after you close the settings tab.

1 Like

Thank you very much for your detailed response, it greatly appreciated.

I followed your instructions to the letter and the result is the same.

This is interesting. I created an SSH tunnel to the PMS so I could access it via Brave with the URL 127.0.0.1:31362/web and it now works as expected.

Does this help narrow down the cause?

Thanks again.

EDIT: This is a hosted PMS if that makes a difference.

Yeah.

It is the content of the URL bar that trigger which policies to use.

So if you log in remotely via app.plex.tv
It will only follow policies set for URLs at that domain.

If you later decide to access the server with some custom dynamic DNS a forwarded port, then the content of your URLbar is probably VERY diffeent.

You need to set the policies correctly for what is now in your URL bar.

It sees two different URLs as two different webpages hosted on two different servers.

One site should obviously NOT be allowed to use policies configured other sites.

1 Like