Brave Shields ad blocker not working after new install


Description of the issue:

Accidentally deleted my Default profile so I re-installed Brave browser. However, once I had installed the newest version of Brave (1.17.73), several issues arose. The Brave Shields no longer worked for adds. It appeared ok and was orange and looked as normal on pages, but it never blocked any adds at all.

The script blocking feature on it however worked, but the adds and tracking didn’t block anything even on YouTube etc even when set to aggressive. On my new tab page it still says “Trackers & ads blocked = 0”.

I found one article that said to refresh the list of items in brave://components/ which are related to Brave Shields, but that doesn’t work either, because they will not refresh, and all of them say “version 0.0.0.0.” and “Status - Update error”. I tried it with the firewall off and it’s still the same. I tried deleting and re-installing Brave again, and it’s still not working. Disabling all my extensions didn’t make any difference either.

My system is Windows 7, 64bit. I haven’t knowingly changed any settings or firewall permissions since it all went haywire, but even with the firewall off, it won’t update or function blocking adds. Any help is appreciated.

Brave Version( check About Brave):

Version 1.17.73 (Official Build) (64-bit)

Additional Information:

brave://components/ does not refresh items.