Over AD Blocking

Ever since this morning, the Cross-Sites tracker is blocking more than it should. First I thought it was because of the browser wasn’t up to date which it wasn’t but even after updating it still didn’t change anything. Because before updating I was on 1.8.86 version and now Im on version 1.8.96.

Can you please provide some additional details surrounding your issue? What is the site that you’re attempting to browse shown in your picture? I assumed it was https://novelplanet.com but trying to navigate there I get this message:

the website that im using uses images from that site im guessing because when copy the entire link and open it another tab it will show the image. Take this one for example.

As I asked previously, would you mind telling me the exact website address that you’re seeing the issues on so that I can test it on my end?


I’m familiar with kissanime – it may just be the .ru proxy that’s having issues. On my end, when I visit kiss-anime.ws the site renders without issue:

If you turn Shields down (or allow ads/trackers) does the site load properly?

yes when i turn shields or just cross site trackers off it works and the site that you mentioned isnt the “Official” KA site which also could be a reason it works .ru is the true KA site because i also tried with scripts which work but the page scroller gets disabled which is whole other can of worms of dealing with

I see. When I try to go to the .ru site the page won’t load – I think because I’m trying to connect from a US based region.

I’m going to tag in one of our Shields engineers here who may be able to find and implement a fix for this issue. It will get filed and addressed either way – thank you for reporting.
cc @fanboynz

1 Like

Okay 2 fixes.

Fixes some Adblock issues. https://github.com/easylist/easylist/commit/05ebad5eadd2bc8874be7b71ce9a0f21139c182c

You will need to also Allow all cookies in Shields.


hate to tell you this but I’m also in US-based region :rofl:

1 Like

I could access it from NZ, if I tried in a US. “You have been banned”. Seems they have a list of known VPN’ ips. I was able to test it correctly, at least from NZ region.

1 Like

I dont what happened between my last comment and now but everything seems to be working now :heart_eyes: