mouse wheel scrolls a whole page per tick

Brave 1.47.186 64-bit on Mint 20.3/Cinnamon 5.2.7; Logitech M220 mouse

Problem: Scrolling a web page with the mouse wheel is unusable because it scrolls a whole page up or down for each wheel tick (i.e. like the PageUp/PageDown keys); this happens on every web site without exception that I could find.
I tried all the highly-rated “smooth scroll” extensions one by one, but none helped at all. My preferred behavior would be a scrolling rate of one line per tick.

Thanks

Hello @jelenc

Thank you for reaching out and I’m sorry to hear you are going through this. Can you try disabling Hardware Acceleration in settings, to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration.

Let us know if that helps.
Regards.

Thanks, but unfortunately it makes no difference.

Hi @jelenc

Thanks for your reply we appreciate the details. Could you kindly use guest mode to see if the issue persist? Additionally, please try to install the Beta or Nightly version of Brave to see if the issue persist?

Be waiting for your response!

Neither “guest window” from the menu nor “–incognito” from the command line make any difference. Can the beta or nightly versions be installed side by side with the stable release? I have to leave soon, so I’ll do it tomorrow.

Thanks.

Hello again! @jelenc

Could you kindly try to going to brave://flags > Search 'Vulkan' > Disable Vulkan > Retest . Additionally, try disabling your extensions to see if this is the cause of the issue.

  1. On your computer, open Brave.
  2. At the top right, click MenuMore toolsExtensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let us know if that helps.

Since I have not seen this mentioned … did you test with a different mouse? :slight_smile:

(note: I am scrolling this post with mouse wheel and it works as expected)

1 Like

Here are the results of the various outstanding tests (all negative, alas!)

  • mouse: Logitech M315 and M325, exactly the same as the M220 (note that all three work better in Firefox, Pale Moon, Vivaldi, and Chromium although they still move up and down by 3 or 4 lines, more than I would wish.)

  • Disable Vulkan: no difference

  • Disable extensions: no difference

  • Nightly version 1.50.20 Chromium: 110.0.5481.77: no difference