Microphone does not work, even when allowed - when minimum shields are on (Any Site)

I have never been able to use any microphone on any website. Google voice, Zoom, nothing. After hours and hours of investigation, I have discovered it’s because the Brave shield blocks access to the microphone EVEN WHEN ITS ALLOWED on a site.

I have verified on multiple sites that this is the Brave Sheilds - even at the minimum protection of Trackers & Ads. It’s just that - the microphone does not work until I disable blocking trackers and ads. This is on any website. I just tested with https://www.onlinemictest.com/ and found the same behavior.

I have spent significant time verifying all my permissions and audio settings and it is not any error there. The microphone works on all other browsers and Windows hears it. Again, I have verified it works in Brave when I disable the shield. (Specifically Trackers and Ads (Standard)) (I have no idea why this text is so large and bold. There’s no option to fix it, sorry for yelling.)

  1. Go to website that wants to use your microphone ( https://www.onlinemictest.com/ )
  2. Allow all permission requests
  3. Test microphone to see that it does not work.
  4. Disable Brave Shield (Specifically Trackers & Ads blocked)
  5. Test microphone again - and see that it works.

Expected result:
When permission is granted to any device - it should be allowed to work regardless of Shield settings. If the data is getting caught up in Sheild’s net, it needs to be fixed as it makes no sense to have microphone permissions if they do nothing. There is a feature on the audio/camera permissions that says “Allow until I close this site” - this specifically should be able to bypass any sort of thing that Shield is blocking. The Sheild protection has little use if we have to disable it for a website to function, especially when there are specific permissions involved for that functionality.

Brave Version( check About Brave):

Ads and trackers won’t affect your microphone. I just tested the site, and it works fine here.

brave://settings/content/microphone Would also check the correct microphone is default in the OS (and in Brave). If that fails, try in a clean profile and retest.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.