[BUG] Microphone won't work when the app is in the background/minimized

Description of the issue:
Callers cannot hear me when Brave is minimized or in the background (I open another app or turn off the screen) if I’m in a call using Brave talk or other voice webapp such us duo.google.com (as desktop mode) or just recording my voice through https://online-voice-recorder.com/

Steps to Reproduce (add as many as necessary):
1.
Launch Brave
2. Visit any website that requires microphone permission, for example https://online-voice-recorder.com/ , or Brave talk or duo.google.com (Desktop mode)
3. Start recording or calling and give permission to the microphone to stay active until you close the tab.
4. Minimize Brave or put it in the background and open another app or turn off the screen to lock screen
5. Wait for 10-15 seconds and speak while you are in another app or have your screen off. The callers or the voice recording webapp, won’t hear you while you will be able to hear them (if you have background video playback on).
6. The recording or the call will still be active but the microphone won’t record until I reopen Brave and am only on the app. This obviously isn’t ideal.

Actual Result (gifs and screenshots are welcome!):
The microphone stops recording the voice when Brave is minimized in the background and using another app (that doesn’t require microphone) or turn off the screen (to lock screen)

Expected R esult:
Microphone should continue working behind the scenes even if the browser is minimized or when I turn off the screen

Reproduces how often:
Always

Brave Version(See the About Brave page in the main menu):
Brave Beta 1.65.89 Chromium: 123.0.6312.58 but it’s the same for the main version too

Reproducible on current live release (yes/no):
Yes

It happens with every Chromium based browser I think