macOS screen reader does not always speak the highlighted text (again)

This issue was fixed for a while but it came back in the latest update.

Description of the issue:
Highlighting text and pressing the speak shortcut does not always speak the highlighted text.

Steps to Reproduce:

  1. In macOS settings > Accessibility > Speech, check “Speak selected text when the key is pressed”.
  2. Go on a website (Twitter for example)
  3. Select text*
  4. Press speech shortcut (option + escape by default)
  • Different ways of selecting text will yield different results.

  • Selecting all text with command + a will usually speak just the first word on the document.

  • Selecting a paragraph of text by double-clicking it will speak some other part of the website (unpredictable on which part - sometimes the previously highlighted > speech-ed paragraph?)

  • Selecting a portion of a paragraph by click and dragging will usually speak what is highlighted.

If I can’t get the highlighted text > speech shortcut to work, I’ll copy it, paste it in the URL bar, highlight the URL bar, and then use the speech shortcut.

Actual Result:

Expected result:
macOS should literally read everything that is highlighted when pressing the speech shortcut. This feature worked fine on Chrome; I only started to notice this bug after switching to Brave.

Reproduces how often:
It depends on the website I am on. Text to speech works fine on Reddit, Twitter, and YouTube no matter how I highlight the text, but on a lot of blogs, I get this bug.

Operating System and Brave Version:
macOS Catalina 10.15.7
Brave v 1.60.125

Thanks for reaching out.
Going to ask the macOS team about this — on my end, text-to-speech seems to be working just fine but it could just be the sites I’m choosing. Can you please share a specific site(s) or URL(s) where you can confirm this consistently happens?

Actually, it might not be related to sites this time. Just command-f and highlight some text. The text to speech will read what’s in the command-f search bar and not the highlighted text. Escape the command-f search bar and the highlighted text can be read.

Well that makes sense to me — when you use Command + F to find text on a page, even after the text is found and the page jumps to the text, the focus is still on the Find box as far as the OS is concerned. You’ll have to click off or press Esc to close the Find dialog box for the focus to change.

Sorry, I should clarify that the focus is not on the find bar and even after highlighting any text on a page, the find bar text will still be read when using text to speech. This is a new behavior that did to happen until the last update

Will have to reach out to some team members about this — will reply back here as soon as have some more information for you.

Appreciate your patience.

Thanks, in the mean time I noticed that text to speech only sometimes works even when the find bar is closed. For example on, sometime, text to speech will read out “Jump to content…”

Can you please update to the latest version of the browser (v1.61.101) and tell me if the issue persists?

How do I do that? I’ve only updated Brave when given the option in the top right hand corner which I don’t see atm.

You can update the browser by going to Menu --> Help --> About Brave and the update (if available) will start.

I updated Brave to the latest version and text to speech will still read what is in the find bar if it is open. Also if the find bar is close and you highlight some text and text to speech it, Brave will copy the highlighted text to clipboard. This is a new behavior that is not helpful.

Text to speech in Brave should work like how it used to up until recently: You highlight text, you use the macos text to speech shortcut, macos reads the highlighted text. Nothing else should happen.

This issue is still happening to me too. Some text will speak, then it’ll cut out. I have to copy/paste the text into a Note and have it read from there. Very annoying and doesn’t happen in Chrome. I wonder if it’s due to Brave’s security features disrupting the feature? Would love to see this get fixed!!!

1 Like

Please revert this change. Brave used to work so well with screen readers.

This issue is cropping up for me as well, I’ve used Brave in the past and never had this issue. Now I’m using Firefox because Brave started having issues with the speak selection feature in macOs.

I tried to narrow down the problem a bit more, but I haven’t succeeded yet. Here’s what I’ve tried and found out. I’m using Brave 1.62.153, which at the time of writing is the most up-to-date version. I’ve also tried to get it working on the current nightly (as of jan 29 '23).

Let’s start with a decsription of the problem, the speak selection function doesn’t work properly. Sometimes it speaks the entire selected piece of text, but more often than not it just reads a short section. It cuts out after a while, but it’s not consistent, sometimes it doesn’t even read a single full word, sometimes it reads a couple paragraph and than cuts out, most often it stopts after a couple words. It doesn’t stop consistently, even when attempting to read the same pice of text, and it doesn’t stop on any natural boundary (like words, sentences or punctuation). It just cuts off mid speech. It doesn’t matter what voice or language I select and I tried fiddling around with the settings in macOs but to no avail.

I’ve tried updating Brave, Also tried disabling addons, but even on a vanilla install the problem occurs. My hypotheses is that it has someting to do with one of Brave’s privacy features, so I tried disabling them, again to no avail. Even a vanilla install with all sields and other non-Chtome features disabled and no addons displays the problem.

Chrome and Chromium don’t have the same issue, but strangely Vivaldi has. So again, my guess is that it is some kind of privacy related feature that’s breaking it, but I’m not at all sure.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.