MacOS: can't make private windows use light appearance

Brave always opens private windows with a dark appearance.

I’ve tried setting “Brave colours” in brave://settings/appearance to:

“Same as macOS” - result, private windows are dark in appearance.
“Light” - result, private windows are dark in appearance.

Normal (non-private) windows display correctly with a light appearance.

Is this a bug or a feature? And is there any way to make Brave display private windows using a light appearance?

Brave Version 1.33.106 Chromium: 96.0.4664.110 (Official Build) (x86_64)

macOS 10.15.7

Thank you.

There is no way to make Brave Private windows appear in any other theme. When you say it appears as “dark”, I assume you mean its default state – as shown below?

Thank you.

Yes, that is how it appears. It’s out of line with everything else - title bar is dark, menus are dark, generally anomalous and out of line with the everything else on my Mac and Brave’s preferences settings.

I feel this should be reported as a bug - could anyone explain why Brave’s private windows on macOS are displayed in this way?

This is because Private windows need to be easily identified/clearly differentiated from normal browsing windows. It is not a bug.

Thank you for your reply. I will investigate how to report this anomalous UI behaviour as a bug, since from my point of view, converting the UI to something which is out of line with the OS UI standard and a user’s explicitly provided preferences is a problem no matter what the intention.

Look at it like this: there are any number of other ways private windows could be differentiated. Using a method which causes UI disruption (without any notification of the purpose) - and in my case, makes the UI significantly harder to use - isn’t particularly sensible.

Thank you again for your time.