Looking for Ubuntu users willing to help test install instructions

Hello everyone!

We’ve recently had an issue with installing Brave from terminal on Ubuntu/Ubuntu builds. The issue is captured here:


[Grabbed from the above issue] Users are receiving an error message:

E: Malformed entry 1 in list file /etc/apt/sources.list.d/brave-browser-release-bionic.list (component)
E: The list of sources could not be read.

If you read through comments in the GH thread, you’ll see that we thought we’d identified the issue:

@[mihaiplesa] That -a has to be taken out from tee in the docs.

This seems to work for some users (myself included) but not for others. I’ve had a couple DMs/replies on here and on Reddit reporting the error persisting.

This is obviously a big deal for us and we apologize for the inconvenience for our Linux users. I’d like to get a better gauge on the situation, so if any Ubuntu users wouldn’t mind testing a few things out for me and posting the results here it would really help us narrow down the scope of the error.
If interested, here’s how you can help:


If you already have the Release build installed on Ubuntu
(click arrow to expand)

Try the following
  • Try installing the Beta or Dev builds using the commands found here
    • If you receive the error mentioned above (or any error I suppose), try the commands without the -a in the tee command. If you’re having trouble locating it, its in the second set of commands that start with the echo statement. So this:

echo "deb [arch=amd64] https://brave-browser-apt-beta.s3.brave.com/ `lsb_release -sc` main" | sudo tee -a /etc/apt/sources.list.d/brave-browser-beta-`lsb_release -sc`.list

Should now be this:

echo "deb [arch=amd64] https://brave-browser-apt-beta.s3.brave.com/ `lsb_release -sc` main" | sudo tee /etc/apt/sources.list.d/brave-browser-beta-`lsb_release -sc`.list
Note: Both the above commands are for Brave Beta, see the above link for commands specific to Release/Dev build.

If you don’t have the release build installed or don’t mind uninstalling then reinstalling a fresh build

Try the following
  • Essentially the same steps as the option above, but I’m specifically interested in the results from attempting to install the release build
    • If you receive the error mentioned (or any error I suppose) using the above install commands, try the commands without the -a in the tee command. If you’re having trouble locating it, its in the second set of commands that start with the echo statement. So this:

echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ `lsb_release -sc` main" | sudo tee -a /etc/apt/sources.list.d/brave-browser-release-`lsb_release -sc`.list

Should now be this:

echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ `lsb_release -sc` main" | sudo tee /etc/apt/sources.list.d/brave-browser-release-`lsb_release -sc`.list


If you try the commands and it works, let me know:

  • Which build you installed
  • Did it work as is or did you have to remove the -a?
  • If this is the first time installing the build on this machine or if you uninstalled first
  • The Ubuntu version you installed on
    For example:

Release build installed
Failed with current instructions, succeeded after removing -a from tee command
First time installing
Ubuntu 18.04

If the instructions did not work using current install instructions or after removing the -a command and Brave was not installed, let me know:

  • Which build you attempted to install
  • If this is the first time attempting to install this build on this machine or if you uninstalled first
  • The Ubuntu version you attempted the install on

I really appreciate anyone who takes the time to test this for us. Even just a few replies can help give a clearer picture of what’s going on.
Additionally, I’ll use this as a “Master” thread for this issue, so if anyone notices someone reporting this issue before I do, please direct them to this thread as well.

Thank you!

EDIT:
Just thought I’d mention to any advanced users or users familiar with the software: you can also try this with a fresh install on a Virtual Machine if you don’t want to fiddle with anything on your primary machine.

Will help with this Ubuntu installation troubleshooting. I have two desktops with Ubuntu 18.04 ( minimal install option ). Other than the known issue with ‘curl’ needing to be installed, there where no issues with the Release version via the terminal on either desktop. Just tried installing the Beta (without uninstalling Release) and this is the output


@mattches before proceeding in any troubleshooting (as this does not seem to be the expected error) is there anything else you would would advise? For reference this is the Release version that is running great on my desktop.

Thanks for reporting! Really appreciate it.
I think what you’re seeing is actually the result of some copy/paste text formatting antics. If you try again you shouldn’t get that error.

You would be correct, will start over. :grin:

1 Like

Installed Beta alongside Release with terminal, with no issues. Have 18.04 (minimal install option).


Tried it out and it works.

Well here I go. After using both the Release and freshly installed Beta I closed both browsers. When I reopened my Release build ( until now no problems / all preferences set/ brave password manager/etc.) the fresh Beta install opened. Tried all icons / shortcuts and they all open Beta only. Then removed beta from Software / Updates / Other Software thinking I would get back my Release build. Did not work.
Tried original icons expecting Release to open and the fresh Beta opens. It was working (Beta) even after deletion from Other Software. Went to Synaptic to remove any builds of brave and found 2 new entry’s under local obsolete and started complete removal. Here are screenshots in order:

Synaptic2

Tried reinstalling Release

Tried reinstalling Release without ( -a)

@mattches Not sure if this helped anything but if we can’t find a solution I will reinstall 18.04 to get Brave back, thats how much I like Brave.

@kbounds56 this is extremely helpful and I do appreciate the effort and thoroughness of your reporting. Looking into all this today, will hopefully have more information soon.

I sent you a personal email. with my solution, please read it . It is simply adding sudo.

1 Like

I’d appreciate someone telling me how to update my copy of Brave in Ubuntu 14.04. The updater keeps appearing, telling me there is an update for Brave but when I choose to install it another window opens telling me this involves downloading untrusted packages and it won’t proceed. It all just disappears until it appears again saying there is an update for brave.

@Highlander1954,
Did you try following the above instructions to install via terminal?

@Mattches just updated to Version 0.56.14 found here http://brave-browser.readthedocs.io/en/latest/installing-brave.html#linux . No problems and did not add ‘sudo’. I noticed the -a not in the new set of commands. Anyway thanks to those that work on the Brave browser as it appears the issue is fixed.
@Highlander1954 be sure to update ubuntu 14.04 before opening a terminal and updating the Brave browser with link above.

2 Likes

@Highlander1954 just noticed that the latest Brave for linux is for 16.04+. I am on latest LTS 18.04. Any reason why you are on 14.04?

@kbounds56, good catch! I didn’t even notice.

I’m using 14.04 because I don’t have a reliable enough internet connection to down load. Last time I tried I totally broke my OS and had to start over with my copy of 14.04. So, until I get get a more recent release on a flash drive I’m stuck.

@Highlander1954 we are getting off topic for this thread. This link https://tutorials.ubuntu.com/tutorial/tutorial-create-a-usb-stick-on-ubuntu#0

should help getting your OS up to date. LTS 18.04 would be my choice. Ubuntu has a great community . When you get your OS up to date you can back and get help with Brave on this great forum. :smile: Good Luck.

1 Like

@kbounds56, appreciate your helping out with @Highlander1954’s Ubuntu woes and for testing.

The docs should all be sorted out now so I’m going to go ahead and close this. Feel free to DM me if there are any other issues installing from terminal and I’ll reopen the thread.