Location issues on Brave

Description of the issue:

The location on Brave specifically says that I am located in Washington DC, US while I am actually in London. I do have location permissions enabled and I tried turning off the shields to see if that would resolve the issue but that did not do it. This affects me on every website. For example, Linkedin will show me jobs in Washington DC, instead of London(where I am located.) This is not a problem in Edge and Chrome.

Steps to Reproduce:

  1. Open brave
  2. Use any website/feature which requires your location.

Actual Result:

Shows wrong location. Shows websites of wrong country. Specifically Washington DC

Expected result:

Get results and websites corresponding to my location(London)

Reproduces how often:

Everytime I use the browser

Operating System and Brave Version(See the About Brave page in the main menu):

OS: Windows 11 Home 23H2
Brave Version 1.64.116 Chromium: 123.0.6312.105 (Official Build) (64-bit)

@arjunlahkar this is very odd. And to be sure, you’re not using VPN or anything like Tor when you’re using Brave, are you? That is my first thought on country being different.

Second thought, does it do the same thing in private window?

Third thought that I wonder is if language selection might somehow have something to do with it? For example:

On that, English is #1 but for United States. I don’t know if there could be anything happening that would default to United States on that. I know it works on some devices, but don’t think it should be here.

Last thought for now, what locale is set for your OS? For example, on Windows 11:

No I am not using any VPN or anything to mask my location.

Also turning on my location from a private tab seems to work fine, for some reason. However, it’s still wrong in a normal tab.

If something doesn’t work right in normal window but works in private, it tends to be because of one of two issues.

  1. Cookies. This is because opening in private creates a session with no cookies and then clears cookies and browsing history from that session when you close it.

  2. Extensions. By default, private disables all installed extensions.

So most likely, it’s one of those. Up to you if you want to first start by clearing all cookies (which means getting signed out of all websites) or with disabling/removing extensions, but it should be one of the two.

Thank you that seems to have fixed it, I believe clearing the cookies worked.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.