Limited Uphold Functionality doom-loop

Since late 2022 I’ve been unable to link my Brave browsers to Uphold. I can successfully log into Uphold. I did my KYC in 2019 and again recently. There are no notices in my Uphold account, but I keep getting the doom loop of “Error: Limited Uphold account functionality. According to Uphold, there are currently some limitations on your Uphold account. Please log in to your Uphold account and check whether there are any notices or remaining account requirements to complete, then try again. For example, you may need to submit more information to Uphold.”

Please advise. here is a lot of hassle associated with maintaining BAT connectivity currently. Even though I support the original vision I’m nearing the point of calling myself a former enthusiast.

@agfoust check out Limited Uphold account functionality

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.