Learn.unity.com not working at all

I am learning Unity, and when I go into a lesson in the course such as https://learn.unity.com/tutorial/lesson-3-2-make-the-world-whiz-by?courseId=5cf96c41edbc2a2ca6e8810f&projectId=5cf9639bedbc2a2b1fe1e848 the website freezes.

learn.unity.com is the site.

I am using the default shields config, and the site breaks both with shields on and off. The site works completely fine with chrome.

My Brave version is v1.3.115

I saw no obvious issues with the site (with no login tested), @Oreztov could you re-test with Hardware acceleration disabled in the Brave settings?

Hardware acceleration did not make a difference, but after testing I can say that login is definitely the problem. When I am logged in, shield or hardware acceleration does not change the site. This is quite strange.

Thank you!

After ttesting on my end, I do see the same behavior as you. What I found is that the site definitely has an issue with Shields. Rendering the site caused my cpu to spike very high and the entire browser slowed to a crawl. One thing I did notice however, is that after a while the site did load as intended – it just took a very long time.

Whats interesting is that there didn’t seem to be anything special happening on the site, and the only blocked items were the types of items you’d expect to see blocked.

Good to know that I’m not the only one, but the problem still occurs even with shields down.
Any ideas?


I’m getting the strangest behavior:

  1. If I visit the site while not logged in, everything runs smoothly and renders very quickly, even w/Shields = Up
  2. If I log into the site, everything slows to a crawl and the page is mostly unresponsive as mentioned before, Shields up or down.
  3. I tried to change Shields settings to Allow all cookies and got the same results. BUT, after changing that setting again, the site functioned properly, signed in, with Shields = Up :thinking:

I wanted to start all over, so I cleared all the site data and permissions, then refreshed – the page loaded while I was not logged in and worked perfectly. I signed in, and then the page…worked perfectly?

It seems that during my testing, some bit of data was set or flipped that causes the site to render normally – problem is I don’t know what that was? @fanboynz – can you take another look?

1 Like

I have done the same procedure as you, and the site works for me too now. So what you have to do is: 1. Change cookie settings in shields to all cookies allowed
2. Change them back to cross-site cookies blocked
3. Sign out and into your account, and everything should be working as usual

Thank you very much! This problem was quite unusual.


I just tested this, I signed in with google and seemed to work okay? (also logged out and re-logged in).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.