Latest macos installer Brave-Browser.dmg appears corrupt

Description of the issue:

I noticed that my Brave upgrade would not go through successfully. The latest version was downloaded successfully but applying it would fail.

I figured my local environment was somehow messed up and removed Brave. Since then I have been trying to re-install it to no avail.

How can this issue be reproduced?

The following scenario keeps repeating itself:

  1. I download the installer from
  2. SHA-256 hash of the installer file is f4d06b278f54492e4b701efc8e749fb1d8b104e1ab6d2b4d2cbb7ee53d060002
  3. Double-clicking etc has no impact and gives no visible error
  4. Running “hdiutil attach ~/Downloads/Brave-Browser.dmg” gives the following output:
$ hdiutil attach ~/Downloads/Brave-Browser.dmg
Checksumming Driver Descriptor Map (DDM : 0)…
     Driver Descriptor Map (DDM : 0): verified   CRC32 $59E9616B
Checksumming Apple (Apple_partition_map : 1)…
     Apple (Apple_partition_map : 1): verified   CRC32 $DD8B1CF3
Checksumming DiscRecording 9.0.3d5 (Apple_HFS : 2)…
DiscRecording 9.0.3d5 (Apple_HFS : 2: verified   CRC32 $E2907692
verified   CRC32 $ECE46314
hdiutil: attach failed - no mountable file systems

Expected result:

  1. Download works, installer opens up and Brave is installed on my laptop

Brave Version( check About Brave):

I don’t know the version as installation itself fails

Additional Information:

My macos version is Monterey 12.6

1 Like

Hello there @mtervahauta, please accept my apologies for this issue. On this case try installing the Beta or Nightly version of Brave to see if the issue persists on those versions.

Be waiting for your response.

Hey Kevin,

I get the same exact issues with the nightly. This is confusing as I imagine this is not an issue that affects all macos users.

Can you share checksum(s) for the latest/nightly installers so I can verify that I receive them intact?

1 Like

Could you please check them here?

Also you can check our repository here

Let me know if that works

I tried both the x64.dmg and universal.dmg from Github, verified SHA256 hashes for both packages, and they still fail to open.

I looked at the package through macos disk utility as well, it gives me the following info:

Trying to mount the image from disk utility gives following error:

Screen Shot 2022-12-20 at 10.49.29

Not sure what else I can do at this point, it seems there’s something messed up about my laptop that manifests itself in a very peculiar way. I will check back later (in a week/month) etc to check if this has improved.

Brave is by far my favorite browser so not ready to give up on it.

1 Like

@mtervahauta on that case I kindly recommend you try installing a different MacOS version on your device to see if that allows you to install Brave properly. We have the system requirements for Brave available here:

I am already using a macos version supported by Brave installer, see version details above.

Either way, happy to report that the latest download works and I have managed to reinstall Brave on my laptop. Not sure what the issue was but case closed for now.

1 Like

@mtervahauta thanks for letting me know that the issue got solved, and accept my apologies once again for this issue.

If you have other concerns, please let me know or create a new community post so we can further assist you.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.