Lastpass is working 90%, except: It tries to re-save already saved passwords, and only on Brave

Description of the issue:
I just installed Brave & Lastpass on 1/12/2020 - it’s working really well - it loads, I can log in, it turns red like it’s supposed to to indicated I’m logged in, when I go to a site it recognizes it, gives me the 1 or more logins, I can connect, etc. If I dont have a log in on that page, it asks me if I want to save it, I say yes, it saves it. So in other words its working perfectly.

Except => It asks me to save log ins when IT JUST ENTERED IT FOR ME - so it knows it has the login, since it just logged me in - then it asks to save it. I haven’t said yes, or it might actually try and save a second one.

  • this does not happen on the very latest Chrome 79.0.3945.117 (64-bit)
  • this does not happen on the very latest Firefox 72.0.1 (64-bit)

So it’s annoying, maybe it could be addressed.

Great job on the browser guys, very pleased.

How can this issue be reproduced?

  1. Install Brave & Lastpass
  2. Make sure Lastpass is logged in, working, filling in passwords
  3. Log into a site with a saved password - if it asks you to save it again, then you’ve reproduced it

Expected result:

  • it shouldn’t ask you to save something it already has - if either you DO let Lastpass fill it in for you, or even if you don’t and manually enter all the information, Lastpass knows it has the password.

Brave Version( check About Brave):

Machine details:

  • OS: MacOS Mojave 10.14.6 (18G87)
  • most recent Lastpass extension => Version 4.40.1 - Updated January 9, 2020
  • Brave version: Version 1.2.42 Chromium: 79.0.3945.117 (Official Build) (64-bit)
  • this does not happen on the very latest Chrome 79.0.3945.117 (64-bit)
  • this does not happen on the very latest Firefox 72.0.1 (64-bit)

Additional Information:
To me this looks like a Browser issue versus a Lastpass issue - it’s working properly on two other browsers - one an identical chromium base (Google Chrome), and one not Chromium-based (Firefox)

Hi, @cswanson. Welcome, and excellent information provision in your post.

I use LastPass all the time in Brave 1.5.27 Chromium: 79.0.3945.117 (Official Build) nightly (64-bit) on macOS Version 10.14.6 (Build 18G1012). I did notice that after an update LP started asking more than once whether I wanted to add newly created credentials, but I didn’t know whether it was a LP update or Brave update that screwed the pooch for it. I chalked it up to lag in updating LP’s database or a subtle change in the subject website’s information that I didn’t notice, but in any case after I told it to save credentials, if it asked again I either saved again and deleted the first one (after viewing both to be sure I kept the right one) or just told it not to save, and it never asked more than twice for a given site, as far as I remember.

What I didn’t have as a reference was using other browsers and the same version of the LP extension. The does suggest it’s a Brave issue (I assume you tried signing up for new sites on each of Chrome and Firefox).

@Mattches, could this be a Shield interfering with LP extension’s interaction with its database and/or phoning home for synchronization?

@hnktong,
Not likely – the only thing Shields interacts with LP (to my knowledge) is if there is trouble authenticating into LP, 3p cookies may need to be allowed on the LastPass.com web page itself. However, seconds after typing that out :point_up:, I went to check and see if that was still relevant – turns out it’s not. I can have 3p cookies blocked on LP.com and still authenticate into the extension without issue.

@cswanson,
Can you clarify for me that you’re saying that last pass will ask you if you want to save a password that’s already saved? Or is it the browser’s built-in password manager that’s asking if you want to save the credentials?

1 Like

@Mattches, I’ve experienced LP asking more than once on top of Brave asking about the built-in, so I’m pretty sure @cswanson means LP’s doing it.

1 Like

@hnktong I assumed so but just wanted to make sure. I’m not clear on why it would be doing this. I’m also unable to reproduce it – LastPass fills credentials and, unless it’s a new site that doesn’t have data saved for it, it will not offer/ask me to save the information into last pass.

@cswanson,
You might consider creating a new browser profile, installing the LP extension there and seeing if you get the same results. If not, it would point to some shenanigans going on with your primary browsing profile’s data.

Thanks, @Mattches. I’ll also try with a new profile to see if this occurs. Please note that we’re talking about newly created entries. For example, last week I created two or three new accounts, and I was prompted by LP at least twice in each case as well as by Brave’s built-in. I’ve returned to those sites since, and I get no prompts from LP to save, as one would expect.

@Mattches @hnktong, guys, very impressed with the response - I hadn’t even checked back since I thought it would take months to get a response - nicely done.

OK, so you know how in github you +1 for a review or if you like something?

Well a total -1 for me, it ended up being the Brace password saver - I had turned it off so long ago in Chrome I forgot that the embedded password saver even existed - once I turned it off, this went away and Lastpass looks like it’s completely working.

If I could go back I’d deleted this entire thread - in fact once you guys read this, please feel free to delete the thread as my mistake. Sorry! ;-(

Excellent browser guys, very impressed!

2 Likes

@cswanson,
No worries! That’s why we’re here :slight_smile:
Glad you got this worked out. Please don’t hesitate to reach out if you have any further questions or concerns.