Block scripts setting has no effect, javascript always enabled


Description of the issue:
The block scripts setting does not actually disable javascript

How can this issue be reproduced?

  1. Open Brave for iOS
  2. Go to Settings → Brave shields & Privacy and enable Block scripts setting
  3. Navigate to websites that detects whether javascript is enabled like https://www.whatismybrowser.com/detect/is-javascript-enabled or https://enable-javascript.com/
  4. These websites report that JS is on

Expected result:
Enabling the Block scripts setting should effectively disable javascript for all websites

Brave Version( check About Brave):
Version 1.46 (22.12.15.19)

Mobile Device details
iPhone X, iOS 16.2

Additional Information:
This bug did not happen for me before version 1.46 (22.12.15.19)

1 Like

Just tested and verified myself. Will tag in @michal and @fanboynz so they can look if it’s something that needs fixed. It is weird how it was showing Java off in the prior and showing on now.

We’ll take a look thanks

1 Like

Oh, forgot to post here. But also been impacting such as can see on my recording at

So scripts definitely seem to be generating after latest update.

And another site. So yeah, definitely not working. I’ll be hoping this can be fixed and patched “quick”, not go another 30-60+ days as we typically have to wait for updates on iOS.


And another site, https://manhuafast.com/manga/the-immortal-emperor-luo-wuji-has-returned/chapter-182/

@fanboynz do you know if is any “fix” to this or if pretty much have to wait for the next ios update to resolve?

FYI: This occurs on my win10 system too. Some new sites that I go to have Block scripts automatically disabled in Shields even though I have block scripts enabled in settings. Didn’t bother me enough to report it before, but thought I would add the information to this post since it is appears the same thing is occurring in win10 OS and not just iOS.

The url examples in the first post are good ones. Tested again just to make sure.

  1. Cleared everything for all time except passwords in brave://settings/clearBrowserData
  2. Exited and reopened the browser
  3. Checked that block scripts were enabled at brave://settings/shields.
  4. Checked that there were no sites listed at brave://settings/content/javascript and
    brave://settings/cookies
  5. Copy/pasted https://www.whatismybrowser.com/detect/is-javascript-enabled in address bar
  6. Shields for the site were disabled automatically on access (ditto for https://enable-javascript.com/)

Same behavior occurs in Beta. Sites tested are working as expected in Nightly.

Bug can be reproduced on the new version 1.46.1 (23.1.5.18) as well

Fixed in version 1.46.2 (23.1.10.20)
Thanks