It violates the following Content Security Policy directive: "script-src *"

NOTE: Any “one-liner” or topics requesting support or reporting bugs that do not make an effort to include as much of this information as possible will not be responded to. Repeatedly posting as such is grounds for banning._
Please try to adhere to this template when reporting bugs. If you think you don’t need to fill out every section in the template fill out as much of it as you can and please be as descriptive as possible when posting.
<---------Delete this line and everything above before posting---------->

Description of the issue:

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:
Some web sites do no display corretly images or do not work.

Reproduces how often:
Every times i go on specific web sites

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 7

Version 1.25.70 Chromium: 91.0.4472.77 (Build officiel) (64 bits)

Additional Information:
Those errors do not happen with Google Chrome.
I disabled the ad-block, try a lot of things, but no change : stil the same error like :

Refused to execute inline script because it violates the following Content Security Policy directive: “script-src *”. Either the ‘unsafe-inline’ keyword, a hash (‘sha256-kP4IIrZEeVmeUeATwBT63XXXnxyUmqK/9FniQkCFq+0=’), or a nonce (‘nonce-…’) is required to enable inline execution.

1 Like

I can reproduce the same behaviour.

Prior the 1.25.72 version (released for desktop on 11th of June), there was a bug that $csp rules were applied even with Brave Shields being disabled.

Could you confirm that there is an issue with disabled Brave Shields while using Brave 1.25.72 ?