Irresponsive KDialog

Description of the issue:
It is not possible to download or upload any file. It takes maybe 20 seconds until the KDialog pops up, then the dialog is irresponsive and it can only be killed.

How can this issue be reproduced?

  1. Press a download link.
  2. Wait until KDialog pops up.

Expected result:

Brave Version( check About Brave):
Version 1.20.108 Chromium: 88.0.4324.182 (Official Build) (64-bit)

Additional Information:
Debian 9, KDE

Hello @kubiznak.petr

could you try in private mode and see if it work fine there or not

if it worked then the issue either with your cache/cookies or with one of your extension

if it did not work then try to create new profile from the menu and see if it work

hope that help and have a nice day :slight_smile:

Hi @justsomeone1 ,

Thank you for your quick reply. I tried all your suggestions but the behaviour is always the same. Btw restarting Brave also doesn’t help.

Any other suggestions, please?

did you installed brave from the official brave site or using snap

Would it be possible for you to share a short recording of the behavior?

Additionally, are you saying you’re unable to download anything at all, or are you only unable to download from a specific site or file type? For example, if you go to and on the landing page, right-click on the White paper link and attempt to download the PDF document, are you able to do so or is the behavior exactly the same?

1 Like

I just realized the issue. I had a mounted network drive which was not accessible - this irresponsiveness should be rather reported as a KDE bug. It was a coincidence that I just installed the Brave browser, so I didn’t think much about other causes. I’m sorry I bothered you guys with a non-relevant issue, and thank you both for quick support!


No worries at all and we appreciate you reaching out. Please don’t hesitate to do so if you have further questions or concerns.

1 Like