iPad Brave cannot connect to local secured device

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue:

How can this issue be reproduced?

1.enter device address
2.Brave immediately enters error site (does not handle user/password entry)

Expected result:
A user and password dialog should appear instead of direct bypass to error page. The process works correctly with iOS Firefox and Safari, as does Brave on Linux. Clearing history, etc. does not help. Home page of device is not accessible.

The device in question is Prolyphix IMC550c thermostat unit

1 Like

What kind of error page is shown? can you do a screenshot of it if possible?

1 Like

The error page is a “401 Authorization Required”. The built-in web server identifies as “Cherokee web server”. In other words, the login process is bypassed

With Brave, I type in the address of the thermostat, but the login is bypassed straight to the 401 page, no login dialog. With Firefox and Safari on the iPad, the process works correctly and connection is granted. This also works with Brave on Ubuntu Linux, just not with Brave on iPad. Otherwise, I’ve had no problems with ios Brave…

Assume the iPad is on iOS 13? Can you try disabling desktop mode from settings and try it again?

1 Like

Actually, iOS 14.0. I tried turning off the setting “Always Request Desktop Site”, but it seemed to have no effect. In fact, I don’t know of a site where it does have any effect. This is the 11" iPad Pro, brand-new. I prefer Brave to Safari or Firefox on this platform, although I tend to use Firefox on my Linux platforms, and was curious why the anomaly on iOS…

Oh, I just discovered, the company project I’m working on, a Battery Monitoring system called “Frontier”, Linux-based OS, uses a web interface served by Lighttpd onboard, also exhibits the problem in Brave: instead of asking for credentials, it goes directly to page “401 - Unauthorized” rather than to the user Dashboard. Firefox and Safari obtain the Dashboard correctly, following login, whether “mobile” or “desktop” page request, which really are the same thing in this case.

=m

Desktop site was just a guess. Going to tag a developer here to take a look at the issue

cc: @michal any insight on why the credentials are not prompted.

I will check this out, looks like authentication popup is not showing, not sure if this could have changed in iOS 14

Thanks!

On the iOS platform, Brave seems to be the browser I prefer. iOS 14 allows me to choose an alternative to Safari as default browser, but so far, only Firefox is available. I understand that Chrome would be, too, if I installed Chrome. Since Brave is forked from Chromium, with cousin roots, could it also have this capability?

If the login were fixed, I’d likely never use the others!

=m