iOS 16.5 and Brave 1.51 - instant crash on Brave open

I have iPhone 13 Pro Max, but after last update to iOS 16.5 with latest Brave iOS browser app crashes instantly when I try to open it (via icon or via link).

I have already installed beta version from the test flight and it works fine (1.52 (, but I have many open tabs on my Brave and I would like to avoid reinstalling of Brave browser if possible.


  1. Open Brave app.
  2. Crash.

Brave version: 1.51 (App Store latest).

As a new user I cannot upload iOS logs sadly.


1.51.1 build is coming which focuses on crashfixes, should be live today.
Sorry for problems

Hi there,
I facing some issues. After I installed the latest version of 1.51 on 23 May 2023 it was working a few hours after that it stop working I am using a iPad Pro 10.5, iPadOS 16.5 I have tried reboot my device and it still doesn’t work. Any advice?

It looks like 1.51.1 is not live yet (at least for me).

Anyone using iOS/iPadOS 16.5 may be facing some issues with Brave version 1.51. Because I used my other device and am not up to date iOS not facing issues on another device.

May I know is this live EST or other timing for the next update and which OS will be having an update Andriod or iOS?

Guys… this is sad. It has been over a week that I’m not able to start Brave browser as it instantly crashes. I’m on 1.51 and there is no update available.

I still cannot upload a log file for you - as I have “new user status” here.

I decided to go with another browser on my phone, I hope to come back one day to Brave so best of luck with fixing this crash.

1 Like

Hi @mtajchert @Aston, we’re expecting to have the fix live soon. I’ll ping here as soon as it’s out. Thanks for your patience.

1 Like

1.51.1 is out, please update and the problem should go away


It works great on 1.51.1! Thanks!

1 Like

I was having this issue with the Brave Browser on iOS 16.5 on 3rd gen iPad Pro. I just updated to 1.51.1 and still experiencing the issue. Anything else I can do?

Does it crash every time at launch for you? or some other crash?

It crashes at launch every time.

Until a few days ago, if I messed around long enough, (restarting the app and/or the iPad, quitting and relaunching, and switching between another open app while the brave browser). I was sometimes able to get the app to start up and give me the app crashed restore tabs message. But for the last few days no matter what I do I cannot get it to successfully launch.

Not sure if you saw my previous message, I am still experiencing the crashes at launch. No change after restarting, etc.

If I were to delete and reinstall the app is it safe to assume that my open tabs would be lost? What about my bookmarks would they also be gone? Thanks for your help!

I saw the message. Tabs would be gone if you did not sync them with another device.
For iPad one thing that worked for people was to detach the external keyboard

Thanks for the fix. It really helps alots

Thanks for letting me know about the tabs. I haven’t had the keyboard attached, I tried messing with attaching/ detaching the smart keyboard while booting the app, before booting, etc., and still cannot get it to start up.

Please let me know if there is anything else I can try. Thanks so much!

Starting yesterday (Saturday 5/27/23), every time that I opened the app it would act like it was opening, stay on a white screen for like 20 seconds and then close. I updated the Brave app after this, to see if it would fix it and it didn’t. I then updated my IPad iOS to the newest version and this also did not solve the problem. I have so many tabs open on there, that I don’t want to lose. Please help! I cannot loose my open tabs! Please! It seems like a lot of people are having this problem and it’s not being fixed. It’s just getting worse. Please fix it!

I updated my iPad to iOS 16.5 and the Brave app to 1.51.1 and it did not fix the problem.

I also have the .txt File, if that would help.

I wrote a review on iTunes for the Brave app, basically stating what I did here. I got a response from the developer that told me to please update to the newest version, which I already did, and and it did not work (Which I already stated in that review). The newest version of the app did not help fix this problem for me at all. And this problem only started the day that the newest version came out. And that same day is when I updated to the newest version. Please help me!

“I am still working on compatibility for iOS devices.00”

Please upload the file and share with us. We fixed bunch of crashes recently but looks like some of them are still happening