Brave Crashes with iPad 16.5 (using Brave 1.51)

Today May 21, 2023: Brave Crashes on Loading. This bug has been ongoing for several days, ever since Apple updated IOS to 16.5 (and earlier, more recent and problematic 16.4 et al releases). Brave purports to have fixed this problem four (4) days ago with Version 1.51. But Brave 1.51 crashes on all four of my trusty iPads. Once the current bug is fixed, I’ll again give it the 5-Star rating it richly deserves.

@Canutosan How about you provide details as they/we request over at Combined Topic: iOS crashing after 1.50

That’s where the developers are tracking and communicating with everyone. Majority of people who were having issues said it’s resolved. So if you’re having issues, may be that something else is going on.

Delighted to assist. I’m a poor reporter of detail, but here’s background that may possibly help. This all applies to iPads (four total) running the latest version of IOS, now 16.5. All iPads are for the 9.7” screen of various generations, Pro models and the more plebeian variants.

  1. Brave has had trouble starting up for many months. Sometimes it would might take two or three efforts, but it never failed to load and function normally thereafter.
  2. By “starting up” I mean clicking on the Brave icon in order to activate a sleeping, non-active app. Immediately prior to this, the iPad was in a sleep mode (self-induced) with the screen powered-off, or I may have switched to Brave from another app.
  3. I have powered down the iPads and tried rebooting to overcome this anomaly. No dice. On each attempt, Brave begins to load/activate, the screen turns white, as if Brave will come alive, then it dies and the iPad app icons and widgets once again make their appearance.
  4. And finally … although I loathed the thought of doing so, because I would lose all my Brave-acquired data, 5+ years of painstaking query, investigation, blah, blah, etc., I deleted the app and reinstalled it.
    And doesn’t it always happen this way? I mean solutions to vexing problems. You do the last possible thing. And, by gosh, it solved the problem. Yep. Did not want to sacrifice my hard won data, but that’s what it took. Brave is up and running. Sweet success! But the sacrifice. A horrible thing to lose your data. It’s like losing your institutional memory. Kinda like this country of ours. There’s an old saying, “Those who forget the past are bound to relive it.”
    Well, thanks for being there. I talked my way to a solution by overturning the obvious stones. Have a good day.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.