Incorrect Rendering of Texts in Some Sites

Description of the issue:

I have an issue in my Brave browser where it doesn’t correctly display English texts in some sites like Brave converts every text in the site into some jumbled Devanagari texts. I checked the same site on Firefox, and it displays fine so there doesn’t seem to be a problem with the site itself. What might be the reason?

How can this issue be reproduced?

This only occurs while browsing sites such as and a few other sites that I don’t remember.

Expected result:

The texts should be correctly displayed in English.

Brave Version( check About Brave):

Version 1.36.119 Chromium: 99.0.4844.83 (Official Build) (64-bit)

Additional Information:

You can change the language in top right.
Normally the website opens in the language of your region or english by default.

I have English US as my default language.

Does clearing the cookies/cache help? @iamsubingyawali also are you using a VPN? or secureDNS?

@iamsubingyawali ,

Might help; and restart computer after making the adjustments:

No, I tried clearing the caches and cookies, but it didn’t work. Also, I am not using any VPN and SecureDNS is turned off.

Also, I have single language, English (US) as my default language.

One new thing I’ve found is, Microsoft Edge also does the same thing. Is it due to any global system configuration on my Windows? Btw, Firefox still works fine.

@fanboynz , @iamsubingyawali , @CerealLover ,

Getting a similar response, using:

Brave Browser iOS v1.35.1 (
Brave Browser Mac OS v1.36.122 (Chromium 99.0.4844.88)

Two Mozilla Support webpages:

Link to the bug language Mozilla page:

That is where I made the screenshots for the image sections on the right:

At the bottom of the following screenshot:

Possibly, WOFF fonts (“Inter” and “Metropolis”) have been hacked?

Or somehow a font substitution occurs because (Developer Tools window - Console report):

Access to font at ‘’ from origin ‘’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.


I did the following experience. I change my language to HINDI in Windows Settings Region. The site opened in Hindi.
Try to change your language to English as in the image.

@CerealLover ,

English has always been the setting. The problem is, how other languages appear, scattered about a web page, as artifacts-almost.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.