Incompatibility with FortiGate GUI & any site with 3rd party MFA

I would like to be able to recall a global Shields settings page as I have had to disable it on practically every Office 365 site I use as well as every FortiGate appliance I manage. Office 365 is easy enough to disable on one or two URLs and be done but not the FortiGates. Having a way to tell Shields to ignore URLs which are just RFC1918 addresses would save me a lot of time! Or at least be able to do wildcard address or subnets.

Description of the issue:
Shields causes constant disconnections while in FortiGate GUI.
Shields does not allow 3rd party authenticators like DUO MFA to function with Microsoft Office URLs for one example. It does not allow DUO MFA to work with any other of our URLs either, same concept as with MS O365 which is a public example.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
I have tried disabling one section at a time to no avail - it would appear the 3rd party tracker option which cannot be globally shut off may be the culprit. Turning shields off entirely is the only way to above examples remain totally functional.

Actual Result (gifs and screenshots are welcome!):
No need. You know what a 3rd party authentication failure does by now I’m sure. The FortiGate page I can screen shot - but to be short, I login and within a second am presented “Connection Lost, please wait” which is the default error the page presents when the client has lost connection to the server (FortiGate in this example).

Expected result:
I think this is a given. I expect to be able to login and have the page function.

Reproduces how often:
Every time Shields is enabled.

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 Pro Build 1803 - 1809 reacted the same on another machine.
Version 0.66.99 Chromium: 75.0.3770.100 (Official Build) (64-bit) - I’ve not paid much attention to app updates recently but its been the same result for a month or more now, since I began using Brave.

Additional Information:
None as of now. Thanks for any help you may be able to provide!