Impossible to visit any page of

Good evening,

I cannot go to any page of
The result is this :

I have disabled AdblockPlus, I have disabled Brave protection : without result always the same page, after recharging also.
On Safari, all is OK.
Thank you for your help.


I installed Google Chrome to compare: same problem…

I’m not able to reproduce this as I’m able to visit Twitter pages in both Brave and Chrome. Can you try (in Brave) visiting a Twitter page while using a Private window and tell me if you get the same results?

thank you for your answer.
On Chrome : I deleted all the cookies and caches : the problem is solved.
Brave : same operation without success. I tried with a private window ; no success. With Brave Tor private window : the site is acessible !

Can you please try (in Brave) creating a temp. new profile and test to see if you get the same results on Twitter using the new profile?

With temp. new profile, the problem persists.

Do you have access to a VPN? can you test from another location?

No, unfortunately I don’t have a VPN and I don’t know how it works.
Thanks again for your help.

download any vpn extension…and try

I installed a VPN and the problem has disappeared.
It’s strange ; but in all cases, thanks for your help.

1 Like

Does it work without the VPN or not? @Kambro

No, unfortunately, as soon as the VPN is disconnected, the problem returns.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.