iCloud redirects if cookies are disabled

bug
#1

Description of the issue:
Today I tried signing into iCloud using Brave. My shield settings prevented iCloud from loading (I had 3rd party cookies blocked, scripts allowed and third party device recognition blocked). In an attempt to correct this I tried disabling all cookies (not sure what I was thinking). Now, when I visit www.icloud.com I get redirected to https://icloud.cdn-apple.com/enable_cookies/ which says cookies must be enabled for iCloud to work. I tried changing my global defaults to allow cookies but it seems that the manual action I took for disabling cookies for iCloud is overriding the (new) global defaults. Because of the automatic redirect by iCloud I can’t figure out how to update the site specific shield settings for www.icloud.com - I get redirected too quickly. Some possible solutions that come to mind:

  1. manually update some configuration file/db brave uses to track site specific shield settings
  2. reset all site specific shield settings
  3. reset all settings - I’ve tried this and it doesn’t complete even after a couple minutes of waiting

**Steps to Reproduce (add as many as necessary):
NOTE: the forum won’t let me have more than 4 links in my first post so I’m not using full urls from here on out

  1. disable 3rd party cookies, allow scripts and disable 3rd party device recognition
  2. visit icloud
  3. disable all cookies for icloud
  4. get redirected
  5. can no longer enable cookies for icloud because of the redirect (or maybe there is a way and I don’t know how)

Actual Result (gifs and screenshots are welcome!):

Expected result:
I expect to be able to log into iCloud. I tried doing this in another profile and allowing cookies for iCloud works (note the color of the user icon is different here - this is another profile):

Reproduces how often:
All the time if all cookies are blocked for icloud

Brave Version(about:brave):
Version 0.59.35 Chromium: 72.0.3626.81 (Official Build) (64-bit)

Reproducible on current live release (yes/no):
yes

Additional Information:

0 Likes

closed #2

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes