Cannot sign into Google 'Cookies are disabled'

Ok this is really doing my head in, I’ve read other discussions about this but there seems to be no clear resolution??? I have cleared cache, cookies and browser history. I have no extensions and everything as far as I’m aware was operating normally and fine and yet now I cannot login to my google accounts and keep getting the same error message:

“Cookies are disabled
Your browser has cookies disabled. Make sure that your cookies are enabled and try again. Learn more”

Please can someone walk me through easily step by step on how to resolve??? I have a MacPro Ventura

1 Like

@TMM you make it difficult to help you because you’re not properly sharing information. For example, you tagged this as ios and macos. Those are two different OS. You mention having Mac Pro. If it’s a Mac, then it doesn’t use ios. iOS is the operating system used on iPhone only. Then iPad has its own which is iPadOS (which is an offshoot of iOS, but still different).

First thing I’ll ask: Can you look at your Shields settings to see what they are like? Two places to check.

  1. Go to Brave’s SettingsBrave Shields & Privacy. Do you have Block all Cookies enabled? If so, there’s your issue.

  2. While on the site you’re experiencing issues, can you click the Shields icon image and see settings there? It should be on Block Cross-site cookies. If you have it set to Block all cookies then that’s your issue.

NOTE If you’re unaware, changes made through the Shields widget (the lion icon) will impact the current site only. It’s a way to override your global settings.

If the above isn’t the issue, it may help if you provide the following details:

  • Specific website this is happening on. (Gmail, YouTube, or what?)

  • Which version of Brave you’re using? (Specific number, don’t just say “the latest”)

  • Which version of your OS? (Like Mac Sonoma 14.1)

  • Have you tried disabling Shields?

  • Does it work in a private window?

  • If you create a new browser profile within Brave, does it work?

1 Like

My bad I’m not exactly tech savvy here, I’m operating MacPro with Ventura 13.5.2.

Block cookies is disabled on my brave browser. This is for every google account, gmail, youtube, the whole 9 yards. I just don’t understand why this is happening now when I’ve changed and done nothing different.

This is my brave version
Version 1.60.118 Chromium: 119.0.6045.163 (Official Build) (arm64)

Yes I’ve tried disabling shields.

Yes it does work in a private window.

I do not know how to create a new profile in brave nor do I want to as I like my profile as is? Or is there a way I can carry everything over?? I guess my point is why do I need to do this to begin with when it should just work on this one?

I have also tried accessing the site with shields down and same thing.

Again sorry for my confusion, again I’m not the most tech savvy individual but I’ve troubleshot most of what people have suggested to no avail.

1 Like

This suggests the issue is because of an extension you’re using. You may want to try removing your extensions. (or at least making sure to disable them)

Go to the Hamburger Menu, imageMore ToolsAdd new profile

image

Your regular profile doesn’t go away. It just creates an additional profile. It uses all of Brave’s default settings and doesn’t have any extensions. So it’s just another good way to troubleshoot and try to isolate problems.

That said, with private window seeming to have the issue go away, you don’t necessarily need to create a profile to test. It’s about a 97% chance or higher likelihood that an extension in your profile is causing your problem. We say this because default settings are that extensions don’t work in private windows. So if something isn’t working on normal windows but it works in private, it’s a pretty solid indication that the person is using an extension that is breaking something.

And just a side note.
I know some people say things like, “I’ve used this extension for years with no issues.” Just in case that’s your thought, any and all updates on the browser and/or extensions can cause problems. They can cause the browser to crash, impact compatibility with websites, mess up your graphics, or any number of things. In the end, it’s all code and sometimes updates can make code incompatible until fixed and result in all sorts of types of issues.

1 Like

Firstly, thank you so kindly for your assistance and walking me through :smiley: I’m a 5 year old when it comes to this stuff normally. I tried New Profile and you’re correct it works. I’m curious though when I disable my extensions (only have 2) it still doesn’t change anything on my main profile any ideas why that is? I disable the extensions, restart browser and attempt again and still no avail.

But yeah so far it seems the new profile works to login to google but ideally I’d like to get the one I’m currently using to works as good. If not can you import all auto saved stuff and bookmarks etc to new profile and migrate it across? Do i permenantly have to remove the extensions I have (Iconnex wallet and Translate)

1 Like

Sometimes you have to completely remove them to see a difference. Why that occurs is something I’m unable to answer. However, that is one possibility for what is happening.

Yes, you can import/export all of that or you can even set up a sync chain between the profiles.

Possibly. I mean, you could install one extension at a time onto your new profile and see if the issue comes back. It might be a better way than having to remove the extensions from your primary profile for testing purposes.

I say one extension at a time because if you install just Iconnecx Wallet and it suddenly has issues, then it’s easy to know that Iconnex is the cause. But if you add it and there are no issues, it would make us guess Translate or the combination of the two is the problem, which you’d test by then installing Translate.

If issue then occurred after installing both, you’d remove Iconnex and see if the issue remained. If issue went away from removing Iconnex, then we’d know it’s only occurring if the two particular extensions are installed together.

But if the issue persists with only Translate installed, it would tell us it’s Translate causing your issue. As you can see, it’s just adding and taking away to check the end results.

The only thing we know is private window and new profile both seem to be working with no issues. As I stated earlier, this is a major indication that it is an extension. So now it’s just having to test with removing them or adding them as mentioned above on the fresh profile.

I would be shocked if this isn’t the final solution, but there are other small possibilities. I’d just appreciate it if you could give it one last attempt. Either completely remove extensions from primary profile or do the one extension at a time on second profile.

Ok all extensions gone, history, cookies, cache cleared, shields off and still no dice :sweat_smile: :joy: Prepare to be shocked hahaha. It’s bizarre… I’ve seen this issue be commented on several occasions over the years and doesn’t seem to be a fix for some, I’m really scratching my head now haha

Think I’ll just have to make a new profile and import it across and use that as the main squeeze. Think it was the only solve for everyone else I’ve seen comment with same issues.

@TMM know what? I have to ask…because I have a feeling I know what might be happening. When you say you cleared cookies and all, how did you do that?

I was looking at a new profile and realized when I went to Clear browsing data, the default was as you see in the screenshot below:

image

Notice how it’s just Last hour for the time range? This would leave a lot of cookies behind on the browser. Ideally, you’d have it changed to All Time.

image

If you didn’t have it set to All Time and we failed to communicate on that, it might be the pissing piece to the puzzle.

Otherwise it is weird because the only differences between normal and private windows is:

  • Private opens with no cookies present. So like if you were signed into Gmail but open in private, it won’t have you be logged in.

  • It prevents extensions from opening (because they can track you, which can eliminate idea of private window). So yeah, by default, no extensions in private

  • History and cookies from your session are cleared when you exit.

I doubled down on the extensions because you mentioned clearing cookies and extensions are main culprit.

Settings would be the same on normal vs private. So generally speaking, it should definitely be a cookies or extension thing. Outside of that I’d be dumbfounded and would have to tag in Support if anything else. But at least we found a way for it to work for now.

Yeah man don’t worry I made sure to go all time, it’s genuinely painstaking trying to troubleshoot it. I am special but not full spectrum haha.

Like I’m adept enough to have navigated my way through probably 7 of these threads with similar questions and fine tooth combing through every damn comment and reply and question/suggestion.

I tried it all and that’s why I ended up getting exhausted and posting it up fresh again myself to see if anyone got to the bottom of it because as far as I’m aware there’s no fix or solution that’s been offered that explains it sufficiently from what I’ve read through.

Everyone has said the same thing too as you’ve said, again which I appreciate immensely man, my god, thank you for the help hahaha! But yeah same kaka again and again

@fanboynz and @Mattches either of you have thoughts on what might be happening?

Unless the cookie settings are changed in Shields url bar, or in brave://settings/shields

Or an extension causing it.

I have no extensions and I’ve turned off all shields, I’ve even gone into setting to manually disable everything

@TMM only since you just responded and I’m trying to think again.

Over at brave://settings/cookies what setting do you have?

And on the very bottom, you should see a portion that says Sites that can never use cookies.

You don’t happen to have Google on that, do you?

Sorry, when I see responses, I tend to want to add more until resolved. Just always trying to figure out anything might have overlooked.

Bruhhhhh :joy: I think we’ve found the culprot, nfi how or why this is like this but we have done it LMAO. Sweet fudging victory.

Sorry for the complicated hassle there but again thank you for the immense help. Scratching my brain on how or why that was there but nevertheless RESOLVED x

2 Likes

Yay! I feel dumb that it took me so long to mention it as a possibility. It just didn’t seem like it should be. Glad to hear it seems like things may be resolved now. (^_^)

1 Like

@Saoiray,
Nice work both of you — sorry I was late to the thread here.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.