I can't download movies and it tells me click on an ad and wait 30 seconds you can see the links for 24 hours

Description of the issue:

I have a problem with a page https://www.pelismkvhd.com/ I can’t download movies and it tells me click on an ad and wait 30 seconds you can see the links for 24 hours I need help @fanboynz @emi please

Exact URL of the website in question:

Screenshot of the ad as it appears in Brave

Brave version (check About Brave):


Seems like it’s a incompatible rule from uBlock *$xhr,3p,method=head,redirect-rule=nooptext:-1 which added some new crap in their rules, method that will cause trouble for Brave. So I just removed that and added the domains, so it is isolated to that site and it works fine.
I remember this site and how crappy it was, seems like at least this works without any other rule.

I don’t know how you got there without getting the anti-adblock in both sites, but I tested that rule and work fine.

Is there any solution about it to add custom filters so as not to disable Brave Shield and not click on the ad on my desktop as for my Android device if you could share to add the filter

well, it is the same crappy website as usual.

the thing is, I tested it, without adblocker and it kind of does that where you click on ad, then it switches tabs and then the countdown starts.

The problem is if you go to devtools, it will not let you do much, like see functions or variables or anything, it is a pain, and I just went ahead and just whitelisted stuff to allow you to download, but if I could see devtools, it would make it easier.

I whitelisted a lot of stuff, and it worked on Desktop but not on Android too well. it’s just a pain.

well then if there is no solution and it is a headache I will have to eat all those ads when clicked. thanks for the answer @emi

gobagames.com##ins.adsbygoogle:style(background-color: black !important; display: block !important;)

As you can see, a lot of things have to be allowed, also, you have to click the boxes if the countdown doesn’t start, but you have to switch tabs for it to work, which means, you can just switch to the one that will have the download link and done, you will see the time going down, rather than seeing ads, even if you are still allowing some google crappy connections.

That’s better than ads, but it is still a terrible website.

Just the old way of switching tabs, that’s kind of what the website does anyway, when you click on an ad it will take you to a new ad.

Also, the reason it wasn’t working on my phone is because recently I reset my phone and forgot to use another DNS than the router’s one, which has Adguard DNS which and since it is filtered, it was blocking connections instead of letting Brave adblocker to redirect them, which is exactly the reason why using DNS adblocking is bad with Brave adblocker.

Anyway, hope it is better with these rules.

I just added the filters but it doesn’t work. but hey don’t worry the only way to download the movie is to disable Brave Siheld and continue eating ads is the only way out thanks for everything @emi

well, it works on my side, normal mode and Private mode.
what doesn’t work? try it in Private mode, it could be DNS, Cache related, like on desktop where I had to close Private mode to properly test it.

Also what platform?

Unless Nightly has something extra (which I don’t think) then it should work.

But it even worked on Tor

Also, do you have to do all this over again or is it every 24h?
Just a question because I think in the future it can be done better, I am testing it right now, but not even 24h.

Also, make sure you are not using a filtered DNS like happened to me.

When I add the filter and save changes and click the link and I open a new tab it tells me disable the ad blocker and reload this window again I tried it in Nightly and Stable and in tor it didn’t work on my pc and it doesn’t work in Nightly either and Stable on my android device

go to brave://settings/security and select in Use Secured DNS with Cloudflare or Google.

That’s the only way it can happen, since Tor/Private is a separate thing from normal windows then cache or anything should matter to think it is something like that, and the only thing that can mess with it is DNS, nothing else, that or another Adblock rule, but not likely.

You are probably running a filtered DNS like happened to me. I just tested with Tor by disabling Cloudflare and I got the detection again, so Tor uses the default DNS for the requests, which makes sense why a filtered DNS would mess with Brave and why Brave should never be ran with a filtered DNS because it messes especially with ‘$redirect-rule’ since this works by redirected the blocked Network requests, but also can mess with $redirect as well.

In Android, the Secured DNS is in Shields & Privacy, like in the middle of the long settings page, so you should be able to test it there as well.
4 braves having the same problem, with 2 different devices, yeah, it has to be your network, like happened to me yesterday on Android.

@emi it worked on my desktop. but is there a way to bypass anti adblock on pc and android. but it doesn’t work on my android device. the step by step what he had told me I don’t know what the problem is in my device here I have the video recorded on my pc

@emi I just went back to the link of the download link and I still get the new tab again, the ad blocking so I want to know if there is a new custom rule to add and skip the anti adblock

well, the problem is they updated the URL, now it is ‘desbloquame’ instead of ‘mega-enlace’

only the first rule has to be updated, which is to bypass the anti-adblock.


If gobagames gets replaced you update all the rules.
When they are domain= you use the | symbol to add multiple domains, like I did for the antiadblock one, and for the cosmetic :style() rule you use comas as inexample,example2,example3##.

If you want to keep the domains in case it changes back to it, but it was only about updating the first rule since that was the one with mega-enlace which now gets redirected to desbloqueame.

All this whole crap is to add a cookie, and I noticed the cookie is also set for desbloqueame just the same, so the trick might work in the future. When Brave implements on Nightly what it has to implement, I will update this and tell you what to do, so you don’t have to do any timer anymore, of course, If nothing changes, in weeks, if not it will be easy to update the rule and just do it once, instead of once every 24h.

ok @emi anything let me know or I’ll tag you if I have any problem with ad blockers thank you very much for everything

@emi I confirm that now it works perfectly. thank you very much for helping me have a nice week

well, the thing is Brave currently doesn’t support trusted-set-cookie that can be used to set the cookie that its being set by the whole timer crap. you could open devtools in desbloquea.me or whatever they use next (even if it throws an error) and go to console and just do a document.cookie= "PeMKgw9e%U1=Wn275;Max-Age=2592000" and done, it will extend the cookie for 7 days, Brave has a restrictions of cookies made by JS to make them available only for 7 days. image

You could do the same, with some HTTPS header modifier and set a cookie on the response header, with just the line PeMKgw9e%U1=Wn275;Max-Age=15778800;path=/; and probably do it just on the main document or frame so it doesn’t get set for other elements.
But that would do it for 6 months image
Of course if they change domains, it will make it not worth it to do it every 6 months. but just so you know.

But the thing is when Brave supports the trusted-set-cookies you can do a desbloquea.me##+js(trusted-set-cookie, PeMKgw9e%U1, Wn275) and done, it will set it every time you go to that page, which means no more doing the countdown to download movies, and then you only need to change the domain if anything.

Also, it seems the PeMKgw9e%U1 is hardcoded in the API in the scripts, so at least that one will not change, but it seems the other one also works, since I used it in Tor and worked fine, so it is not attached to the computer and all that, you probably check devtools and should be the same.

So yeah, for now using Devtools would at least allow you to do it every 7 days, and not everyday, everytime you see the green Ir al Enlace button, you have to just open devtools, probably use the up arrow to bring console history items or whatever, then it will be set, close, click the link in the enlaces públicos and done, it should be green again.
I mean you can see in the Expires on the cookie, how it is a 24h thing, so giving 7 days will just extend it unless they change domains.

well thanks for the advice @emi I’ll keep that in mind hopefully Brave added new features to these themes to address these issues

The new 0.8.0 says it supports the Trusted, because the point of the trusted set cookie is to be only for Default lists and custom filters, not custom filters, the normal set-cookie is restricted to few values and only from 0-15 in value.

It is for security measures, so the trusted will allow any value.
I already use it, I had to sideloaded, but when it supports it, then you can use that, of course, it is not something that will be added to a default list or anything, but it will be easier for users to deal with some stuff when Trusted scriptlets are supported.

But you can manually open devtools, and just type 2025 or something and it will set it to the max value it can do it, so that could also be a way of doing it. Just so you know you don’t have to do the countdown every 24h.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.