Site detect ad blocker detected

Description of the issue:

hello when i want to download a movie from my pc and my android device says
Disable adblock for this site. I tried it on Nightly and it’s stable and it doesn’t work.

Exact URL of the website in question:

Screenshot of the ad as it appears in Brave

Brave version (check About Brave):


If you want to download movies, you can always create custom rules until fixed:
that notice is easily done by using:

The problem is you need to click an ad to be able to get the download link, seems like just alt+tabbing will somehow activate the link, if not opening devtools with F12, will also make it work.

That will make it work until it gets properly addressed by Easylist/uBlock teams.


thanks @emi now if the custom filter and F12 works now we have to wait for the easylist team @fanboynz to address the problem of my android device to avoid clicking on the ads and download movies thank you very much @emi for all the help.

Unless there is something blocking this domain (pi hole/dns/extension etc), its already covered. I tested in Brave release/beta, didn’t see any messages with default shields

@fanboynz the problem is not but when you click to download a movie, in the case of avatar is DropBox | GoogleDrive | MediaFire | Mega | UptoBox | 1Fichier

Even uBlock doesn’t work. is the website that has that which gets blocked but needs redirection to work.

But the problem is when it asks you to click on the first ‘google search’ results to go where you can’t see the ads to click on, to get the timer on the other tab to get the links.

for that you need to allow two scripts, and

The problem is the buttons still don’t appear because there is a generic cosmetic ##ins.adsbygoogle hiding them.
So I had to use ghide for that, which as custom filters doesn’t work for default lists so it is tricky to do that.
I also had to add ||*$subdocument,redirect-rule=noop.html, to make the buttons appear clickable.

which you can see here:

so to get the ‘clickable’ area displaying, I just created a :style() with a black background because the buttons are there but not showing for the way Brave does the automatic stuff on iframes.

This is how it looks in uBlock, where I only whitelisted the googlesyndication scripts and because it is not doing whatever with the iframes then it doesn’t collapse them and it’s easier to click on them:

So yes, It is a piece of garbage website.

I searches in uBlock uAssets and they removed the $ghide from the filter rules, because it was showing whitespaces when you go to watch news, but then, it hides the buttons that have to be clicked to download movies in this case. Althought it only needs that genetic cosmetic exception not all the exceptions.

That change was made in february 11th

I am sure there are easier ways to make it work, I just found the most technical and complicated because I wanted to see what that website is even doing and how to really fix it in Brave.

oh and yes, alt tabbing or going to devtools for some reason “clicks” the ad, but of course, that method won’t be known by anyone who goes to that page.


The problem is that I have to click on the ad to be able to download the file on my Android device. How can I avoid clicking on the ad so that it takes me directly to the download link? Is there any solution?

Switching tabs on android did the same trick as switching tabs or opening devtools, so that should be the workaround.

hello @emi I just recorded a video if I’m right or not correct me if I’m right what I did oh no. Oh, if you have any screenshots, could you share the steps to avoid clicking on the ads?

I touch the page around before switching tabs and it seems to do the trick, it seems like it doesn’t work if you just switch tabs right away.

The way to the site is designed using external links/website. Can’t really change this

thanks @emi the same works with the trick but you have to be patient to wait for the 30 second ad to skip.

I would have liked that private DM messages could be enabled at to address any questions or a problem. I wish it could be enabled this year.

ok no problem thanks @fanboynz

Followed the flow, and there is no link to any download.
Opening 3 new tabs, that actually you are making organic search for a site that seems related to crypto(hope their intent is good, and not preparing for a scamm).
Isn t easier youtube-dl and CLI for downloading mp3/mp4 from most of sites?


Try these rules in your android phone:



||*$subdocument,redirect-rule=noop.html,[class="adsbygoogle"]:style(background-color: black !important; display: block !important;), ,*,0.2)

You get the click on android, which I put them as a black box.

Also, the timer is not an ad, it is a timer set by the page to make you wait and probably make you pay for VIP.

The timer can be speed up with nano-stb. You still have to wait, but it will be faster ow, I left it at 0.2, because it was causing errors to go lower to make it faster, I tested 0.05 and it was really fast, but always marked an error.
So it is something you can change if it is causing problems.

This is the kind of BS this website is, because allowing some scripts generate other scripts which means there is no workaround it, but just allowing them, so stuff inside the page can be generated accordingly.
In fact, if you don’t allow the redirection of frames from doubleclick, the ‘optimizers’ won’t be generated properly, so the page is a big mess connected to ensure you allow the ads through.

Hope it works for you, but no more tabs switching but more ads/trackers allowed.

1 Like

hello @emi I tried the rules and if it worked for me thank you very much it goes like an arrow good job :+1:

Hey @Emi , where exactly can i place this rules in my android device?
Thank you!

@Michael-Alexander you have to go to settings and type Brave://adblock and paste it in the custom filter at the bottom below

1 Like

New tab, type brave://adblock
and at the end of page, in the “Custom filters” box, insert the mentioned lines by @Emi

It seems that once typed there, it s remain saved and no needing any action.

I am glad it worked, it is still a terrible garbage website, but at least it is better than dropping all shields to download a movie. Something is better than nothing, even if I had to find workarounds to do the simplest thing.

As you could see I didn’t even get a simple answer for a simple question asked, even if it was just a “yes or no” type of thing but whatever, I guess at least I could help you guys find a workaround to make it work even on Android, without doing some magic tab switching or something.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.