How to revert to earlier version of Brave for Linux?

I’m using Brave version 1.1.23 in Kubuntu Linux 18.04 LTS. In the last several weeks, every time I open Brave, the screen blinks intermittently and then Brave closes on its own after a few minutes. I have cleared cookies and cached images, and disabled hardware acceleration, but these measures haven’t helped.

I have only recently started to use Brave more regularly, so I don’t have a good read on the issue, but I think it’s been going on since around Brave version 1.1.20. Browsing around the Brave Community forum, I see that several other people have reported the same or a similar problem. Therefore my question is: pending resolution of the issue, Brave is unusable. How do I revert to version 1.0?

The same problem occurs in Chromium (version 79.0.3945.79), but not in Firefox.

Please note: I am fairly new to Linux, so the more detail provided in the instructions the more helpful they will be.

Thank you!

@Cybertooth,
Thanks for reaching out. Have you enabled automatic crash reporting in the browser?


In addition, you can download previous releases of the browser on our Github:

This is what I do:

sudo apt install brave-browser=1.01

sudo apt hold brave-browser

Hopefully they’ll fix it in the not too distant future, but it’s impossible to use in its current state with anything newer than version 1.01.

1 Like

Hi Mattches,

Thanks very much for the info on how to get previous releases. I would need to uninstall the current version, right? Coming from the Windows world, I don’t yet have a good handle on how to do these sorts of things in Linux.

To answer your question: yup, I do have automatic crash reporting enabled, so hopefully these are helping the developers to figure out what’s going on.

Thanks, that will come in handy as soon as I learn how to uninstall the current buggy version!

I see that I could do it via the Synaptic Package Manager, but it gives me the choice of “Mark for Removal” or “Mark for Complete Removal.” Not sure what the difference is between removal and complete removal.

If you run the first command, it will DOWNGRADE Brave Browser. The second command will ensure newer version’s don’t get updated until you UNHOLD Brave.

I just tried the first command, to downgrade Brave to 1.01. Here’s the output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Version '1.01' for 'brave-browser' was not found

Bummer…

If you have synaptic installed on your system, here is what should work.

Launch synaptic (you will probably be prompted for your password)

Click on Search and search for brave - you should find brave-browser

Click on the brave-browser entry

On the menu select Package and then Force version…

From the dialog presented you can pick from the available versions. 1.0.1 should be listed

Click on Force Version which will close the dialog.

On the menu click Apply, answer Apply on the dialog which comes up and the old package will be downloaded and installed in place of the defective version

Finally select the brave-browser line in the list, Click Package on the menu and select Lock version. That will hold brave at 1.0.1 until you uncheck Lock version.

Those are the steps in synaptic on Linux Mint. The steps should be the same on Kubuntu.

Let us know if that works.

Ken

p.s. If you do not have synaptic you can install it from a command line (terminal)

sudo apt-get update
sudo apt-get install synaptic

I don’t have kubuntu handy but it is probably installed on the menu tree under Administration or just type synaptic in the terminal.

Wow, that did the trick!! :+1: Brave 1.0.1 has stayed open for about ten minutes now, and there’s no blinking on the screen.

Thanks so much to you and to all who pitched in with ideas, this has been an educational experience. Hopefully this solution won’t be needed for much longer, but for now it’s doing great. Since Chromium was having the same problem, I’m going to leave their new buggy version installed and try it out each time they release an update, see what happens. Once they get it fixed, then maybe I can bring Brave back up to date again.

Yes, sorry about that, missed the fullstop. Should have been 1.0.1

Glad to see you have the older version locked in. On Linux Mint I find that Brave is very sluggish as I try to scroll down a page - even the internal settings page. I had not let it run long enough to crash. Keep an eye on the status of Brave as running an out of date browser is not a good idea.

Synaptic is a very powerful package manager. In Linux a package is sort of like a program in Windoze. In Linux, however, rather than downloading a package one time and installing it the preferred way is to install it from a repository or repo. That is what Synaptic (or aptitude, apt, apt-get on the command line - they are all essentially the same) does. By installing from a repo the package manage or update manager will discover that an update is available and can either update it automatically or with your permission depending on your preference. You do not have to go back to the provider of the program, download the program and install the upgrade manually.

Feel free to join the forums over at linuxquestions.org as you explore the features and benefits of Linux.

Ken

1 Like

@taylorkh and @infidelus, thanks for the additional info.

I left Brave 1.01 open overnight and am happy to report that it’s still right where I left it.

Will definitely check out linuxquestions.org!

After recent upgrade (1.1.23) I have the same issue, sluggish when scrolling down. Also happens when typing (for example this message). Need to downgrade. I filled proposal to release brave to stable channel less frequently, or make a new release channel “very stable”: Release to "stable" channel less frequently
As of now it is not feasible for business.

1 Like

1.2.41 appeared in the update manager this morning. The sluggish scrolling is still a problem :frowning:

Last night I installed Brave version 1.2.42, along with something called “brave-keyring 1.8”. As an experiment, I left the browser open to its home page (DuckDuckGo) overnight.

To my surprise, Brave was still open this morning when I came back to my computer. However, within a minute or two after starting to actually use it, Brave closed itself down.

So the situation has not improved.

Please allow me to correct a couple of my prior posts. The sluggishness in scrolling with Brave 1.2.4.x is NOT a Brave issue. After some testing of the browser on CentOS 8, Ubuntu 18.04 and Mint Mate 19.2 on a physical machine… long story short I found that the cause was having “ Accelerate 3D graphics” disabled for the Mint Mate virtual machine on which I had been running Brave. What 3B graphics have to do with a browser I do not know. Bottom line it was a VMWare issue, not Brave. Sorry for any confusion.

Ken

The situation is not improving. I just installed version 1.2.43, which just announced itself along with other Kubuntu updates, and after opening it the Brave window went Poof! in less than one minute.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.