How to make Brave not open multiple windows from different shortcut

Description of the issue: Brave open new windows when I open it from taskbar, desktop or Start Menu. How can I stop that and make Brave open in only one already opened windows regardless of where I click it.

I’ve solved this problem before but I forgot where I found it. I remember I had to edit some registry key.

Bump this thread. Please give some solution

Welcome to the community.

Posting a topic that may help. The problem was on a macOS system but I think the troubleshooting steps would be the same. Can you test and see if this works for you?

Topic: Multiple window opening problem

  1. Check: brave://settings/getStarted
    Multiple window opening problem - #16 by Mattches

  2. Change On startup setting, does it change behavior?
    Multiple window opening problem - #18 by Mattches

Please post an update and include your Brave and OS versions found at brave://version if the issue still occurs. Hope it works!

Thanks for your reply but this isn’t the problem that I have. I have Brave on desktop, pinned to taskbar and startmenu. I just want all of them to open in 1 window when you click. Like when you minimized a program and open it again.

I’m still not sure what you are asking. Just going to throw out some information that might cover your inquiry. Please post an update especially if I am still misunderstanding what you are asking. Hopefully another community may understand exactly what you are wanting to do and provide more information.

If you open Brave from any location (taskbar, desktop, startmenu) and then minimize the window, you can use the taskbar icon to open that same instance. If you are clicking the taskbar icon and it always opens another instance instead of minimizing/opening the existing instance, you may have sticky keys enabled. Pressing shift key quickly 5 times in a row should turn it off. See article linked below for more information.

Using the desktop icon will open a new instance. The startmenu icons will open new instance if no other instances are open, open the minimized instance if it is the only instance, or open the last instance used if you have multiple instances open. At least that is how it works on my system. I am on win10. Is this the behavior you are trying to change?

If you mean you have Brave Release, Beta, and Nightly all pinned and want to open them simultaneously, again, as far as I know, you can’t. You could probably write a batch file to do that. If this is what you are wanting, you may want to head over to windows help/support for information on how to do that or do a web search. Lots of information out there.

The article linked below may apply. There are instructions for changing registry keys, but you can also ctrl-click an icon in the taskbar to do the same thing.

it’s worth noting this behaviour is built into Windows, although in a far-from-obvious way. Holding the control (Ctrl) key while clicking on a taskbar icon will always open the last active window, no registry hack required. If you only occasionally need this behaviour, holding the Ctrl key might be the best approach for you.

Yeah this is the problem that I’m having. Startmenu icon and desktop icon always open new instance even there is already opened instance.
I don’t remember where I found resolution for this problem earlier. I just remember I had to edit some registry keys to make it works.

//Take Steam as example: Steam only open in 1 instance regardless of where you open it(desktop, startmenu, taskbar, file explorer,…). But it’s not the same with Brave.

Yeah, I confirm. But I think that works as intended based on the shortcut associated with those.

The best way to do what you’re mentioning is to pin Brave to your taskbar. Mine currently says Unpin because I have it pinned. But you get the gist of it.

So while Brave is open and the symbol is in Taskbar, right click and pin it. Then the symbol will remain there regardless of whether Brave is open. It then will default to opening on current page, rather than new page. In order to do new, you’d have to Shift + Click on Brave in the Taskbar or you’d have to right click and New Window.

I know you said you pinned to Taskbar before and had issues, but I can’t replicate. I just wanted to confirm with you and show what I just tested.

Other thing to consider is if it works like Chrome does, which I’m not testing, then if you have 2 different Profiles active, then it sees each one differently. Such as if Profile 2 is pinned but then you’re in Profile 1 while surfing, hitting the pinned one attached to Profile 2 will open a new instance as you’re not running Profile 2’s.

May be non-solutions but wanted to go through all of that in case it was something simple being missed. If you start from scratch there using that info and still have issues, then we’ll get the professionals involved. (though with it being Friday, probably won’t be until next week)

2 Likes

Yeah I already did this but still same issue. It’s annoying that sometimes I play games and don’t have access to taskbar so I have to open Brave by startmenu hotkey, and it opens a new instance instead of already minimized instance.

Well, I know start menu usually links like that by default, so of course is the issue. That said, Taskbar should do what you’re wanting. But I get you’re saying you want an option other than.

I’m not sure which type of game you’re playing, but if you’re on something like WoW or Final Fantasy XIV, you can set it to be in Windowed mode which will let you toggle from that screen to things like your web browser more easily. I used to do that and Alt + Tab over if I remember right.

There’s also always the Windows button + D to return to desktop, where your game would continue running in the background but it would give access.

Again, those are more workarounds compared to solutions you want. I know Chocoholic is working with you and may have a solution. I’m going to tag in @JimB1 as he’s another User with a lot of knowledge and he might know. Otherwise we’ll see if @Mattches might be able to swing by with an idea of what you need to do for Brave to not open in new when clicking on it in the Start Menu.

1 Like

I believe the last time I resolved and issue like this it was due to a user having a specific extension installed — I’m wondering if you remove any of your installed extensions if you still get the same behavior?

Just wanted to add a thought that might help. When I am playing a game in full screen, I can use alt-tab to cycle through open programs in task bar. Have you tired this? Does it work or what is problem if doesn’t? Of course, if it is an extension as Mattches suggested might be the case, you can ignore this!

Glad to know the information I provided actually related to your issue! Whew, glad that’s settled. :slightly_smiling_face:

1 Like