How to get rid of Download Google Translate popup

How can I stop this from happening on every page load. I can’t find anything in preferences and I’ve tried to search for a flag in brave://flags

7 Likes

This would be good to know. I wonder if right-clicking the icon it shows will give an option to tell it to stop offering?
image

Unfortunately, nothing. You can’t right click on it.

Does anyone have an idea…? This is really bugging me…

2 Likes

I have same problem. It is annoying. I think there should be an option as “dont ask again”.

1 Like

@Mattches, could you weigh in?

Hi everyone!
Sorry for the (very) late reply – not sure how this one slipped by me.
So in order to get the installation prompt to stop appearing:

  1. Menu --> Settings --> Languages or (brave://settings/languages)
  2. Click the down arrow to expand the section
  3. Toggle the Offer to translate pages that aren't in a language you read option off.

You should no longer be prompted to install the extension.

11 Likes

Great. I didn’t had that option. I had to reset the settings back defaults and then I had something to un-toggle. I must have made changes to languages and not realizing it.

2 Likes

Thanks @Mattches! The solution works for me too and problem is now gone :smile:. That super annoying bug-feature started appearing today. I understand the translation offer might be useful in some situations but for many of us it’s just irritating and annoying.

Maybe the default should be set to off to save us foreigners this trouble.

I guess however Brave does it there will always be some complaints. Can’t please everyone. At least I am happy right now.

2 Likes

If you want to use translation but not the popups, one solution is to install the Google Translate extension from the Chrome Web Store!

2 Likes