Brave forces me to install 'Google Translate' plugin

Description of the issue:
On almost every page I visit I am experiencing annoying popup about installing ‘Google translate’ plugin. There are only two options to choose: Install and Cancel. The latter works only temporary and my choice is not being kept neither the same page visited later nor any different page. This popup violently forces people to install this add-on that will probably send all page data to google.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Configure environment in a way that make all algorithms think that you are not English speaker. (e.g. Windows language, Regions, Time zones, language settings etc.)
  2. Install Brave
  3. Visit any page with English language being used on that page

Actual Result (gifs and screenshots are welcome!):

Expected result:
Getting rid of this altogether or at least give me choice once and for all

Reproduces how often:
Every freaking time :confused:

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 Version 1809 (compilation 17763.775)
Brave: Version 0.69.132 Chromium: 77.0.3865.90 (Official Build) (64-bit)- currently shows that is up to date

Additional Information:
N/A

2 Likes

@ przemyslaw.juszczak

I had the same problem. There is a solution available in the below thread. Annoying pop up now gone. Good luck.

6 Likes