Google translator popup terror got me tired

why is that google translator poping up all the time. and why is it by default. and why can’t find a way to disable it. and don’t tell me its in the language settings because its not. I am using brave browser on my mobile and i am sick of beeing asked every single fcking page i visit . brave please fix this. at least let the community know about this stpid changes and make it possible for the user to enable or desable.

Me too facing same issue I am brave browser user since 5 years There always difficult in translating some times pop up shows unable to translate Why this occur always?