How to delete saved emails

I have saved emails for log in, one is incorrect and one is not used anymore and I wish to delete. I have looked and found one thread about this, I still have an issue an this was not solved in the thread.

I have gone to settings/Additional settings/ auto-fill/addresses and more. This is where I get stuck.

(I do have a screen shot from the thread, but can’t attach)

Under the “add” tab on the page there is meant to be 3 dots. There are no emails listed in my list and there are no 3 dots to click on to make them show.

I need to delete the incorrect saved emails for login.

I would attach a pic of my screen, but don’t seem to be able to do this

Brave version:
Version 1.0.1 Chromium: 78.0.3904.108 (Official Build) (64-bit)

Thanks, help would be appreciated.

Hi @Heather7,

Head to brave://settings/passwords in the Brave browser’s URL bar. You should see a list of all your password autofill entries here. Can you double check for me that it’s not showing up?

Are you using any external password managers such as LastPass or 1Password? Could be that the password is stored there, but not in Brave. :slight_smile:

You can also try clicking the saved passwords button while you’re accessing your email. It’s a small key icon that comes up on the far right side of the address bar when you’re logging in. From here you should be able to delete the one entry you don’t want. :slight_smile:

Hi Asad,

when I go to settings/passwords, this is what I see. If I click on the 3 dots, it just says ‘import’.

No, I am not using an external password manager. I have not set one up and I think I would have to to have one.

When I go to put my email in to Coinspot, the 4 emails come up in a drop down menu. There is no key to show and I can only click on the email, nothing else. I have tried right clicking, but am unable to do anything. There is also no key on the password, but this is not the problem.

I have contacted coinspot, but they say it is a browser problem. :frowning: I have attached a pic of the coinspot login as well.

Please advise.

Heather

brave://settings/passwords

Can you try clear your auto fill via brave://settings/clearBrowserData?

Hi eljuno,

You are a genius!

Yes, I had to go to Clear browser data, (I had done this before, but not through this tab under preferences)

I had to go to advanced settings and then I ticked everything down to autofill form data. I had to clear all time and that is where it showed up as having suggestions.

I cleared this and that worked.

Thanks,

Heather