How do I stop Brave from closing when I close the last tab?

Description of the issue:
When I close the last tab, I want the browser to remain open. How do I do that since there’s no setting for this?

How can this issue be reproduced?

  1. Close the last tab.

Expected result:
The browser should remain open!

Brave Version( check About Brave):

Version 1.28.105 Chromium: 92.0.4515.131 (Official Build) (64-bit)
](https://brave.com/latest/

I just made Brave my default browser, but this issue is a game stopper for me.

2 Likes

There is no remedy as you state here.

But, there is a workaround that I use. I keep the Bookmark Manager (Ctrl-Shift-O) open on the far left of the tab strip/row and then pin it (so it doesn’t take up much space on the tab strip/row).

Now, when I close my tabs, I still have this pinned tab open and keeping the browser from closing.

You can disable the option on Brave mobile. I don’t know for pc.

Just curious, what is your goal for this? Just looking to reduce startup time or is there some other issue with the browser closing out?

Good luck with that. I’ve requested this little thing ages ago and done it again and nothing happened after months if not years at this point:

1 Like

I just like having a clean slate. I often have several tabs open and when I finish with them, I close them. That tells me I have nothing else to attend to on that site. Yet, I still like to have a window open. Personal preference.

2 Likes

The extension Don’t Close Window With Last Tab works for me, but they give no info under Privacy Practices in google web store so it’s not without some uncertainty.

I suppose if it were me I would use Ctrl+N to open a new window, Alt+Tab to switch to the previous window, and Alt+F4 to close that one. Not perfect but just a couple keystrokes, and no extensions or other modifications needed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.