How do I disable the inline tip button?

Description of the issue:
Appearance of a “tip” button, added to shadow root on github pages.
Tips turned off for all sites in Brave Rewards settings panel.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Go to github and browse the commits of a repository.

Actual Result (gifs and screenshots are welcome!):

Expected result:
No tip button should be added to github (or any other sites).

Reproduces how often:
Every time.

Operating System and Brave Version(See the About Brave page in the main menu):
MacOS Catalina 10.15.7
Brave Version 1.18.70 Chromium: 87.0.4280.101 (Official Build) (x86_64) (

Additional Information:
I have searched for “rewards” in the settings, and turned off/disabled rewards wherever i’ve found it, but it still shows up.

Can you make sure the issue still persist after browser restart?

It looks like the button disappeared after browser restart.
Is there a way to opt out completely from Brave Rewards so I don’t have to chase down settings pages every time there’s a new update?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.